aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-editing-services/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gst-editing-services/APKBUILD')
-rw-r--r--community/gst-editing-services/APKBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/community/gst-editing-services/APKBUILD b/community/gst-editing-services/APKBUILD
index 1dfe36d8bf3..9028c754edb 100644
--- a/community/gst-editing-services/APKBUILD
+++ b/community/gst-editing-services/APKBUILD
@@ -1,29 +1,44 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-editing-services
-pkgver=1.20.3
+pkgver=1.22.8
pkgrel=0
pkgdesc="GStreamer Editing Services Library"
url="https://gstreamer.freedesktop.org"
# s390x blocked by 7 failing tests
arch="all !s390x"
license="LGPL-2.0-or-later"
-makedepends="gstreamer-dev gtk-doc python3 gobject-introspection-dev py3-gobject3-dev
- glib-dev gst-plugins-good gst-plugins-bad-dev gst-plugins-base-dev
- libxml2-dev flex meson"
+makedepends="
+ flex
+ glib-dev
+ gobject-introspection-dev
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gst-plugins-good
+ gstreamer-dev
+ gtk-doc
+ libxml2-dev
+ meson
+ py3-gobject3-dev
+ python3
+ "
subpackages="$pkgname-dev $pkgname-doc"
source="https://gstreamer.freedesktop.org/src/gst-editing-services/gst-editing-services-$pkgver.tar.xz"
options="!check" # https://gitlab.freedesktop.org/gstreamer/gst-editing-services/-/issues/125
build() {
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
+ CPPFLAGS="$CPPFLAGS -O2" \
abuild-meson \
+ -Db_lto=true \
-Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -31,5 +46,5 @@ package() {
}
sha512sums="
-380cea0abda043a5aaee11981c85a03e59f4a5ac9221342c09d1875477dc327210ad0705e537538a981bef4de99b1aa7ac92fb37c77fc60b44219d673f97f56f gst-editing-services-1.20.3.tar.xz
+d4fd0c6a4143a0cd40d2299461d2d2903fab79ba1cb03d45f6206254c28b327a07b0fe45b12a1deeff86bd442a3cc4e7110822b2ca69362572333e24f88bbc69 gst-editing-services-1.22.8.tar.xz
"