aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-editing-services/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gst-editing-services/APKBUILD')
-rw-r--r--community/gst-editing-services/APKBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/community/gst-editing-services/APKBUILD b/community/gst-editing-services/APKBUILD
index 8bed0bb6647..a6bd5702a07 100644
--- a/community/gst-editing-services/APKBUILD
+++ b/community/gst-editing-services/APKBUILD
@@ -1,28 +1,44 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-editing-services
-pkgver=1.18.5
-pkgrel=0
+pkgver=1.22.11
+pkgrel=1
pkgdesc="GStreamer Editing Services Library"
url="https://gstreamer.freedesktop.org"
# s390x blocked by 7 failing tests
-# mips64 and riscv64 blocked by librsvg -> gst-plugins-bad
-arch="all !s390x !mips64 !riscv64"
+arch="all !s390x"
license="LGPL-2.0-or-later"
-makedepends="gstreamer-dev gtk-doc python3 gobject-introspection-dev py3-gobject3-dev
- glib-dev gst-plugins-good gst-plugins-bad-dev gst-plugins-base-dev
- libxml2-dev flex meson"
+makedepends="
+ flex
+ glib-dev
+ gobject-introspection-dev
+ gst-plugins-bad-dev
+ gst-plugins-base-dev
+ gst-plugins-good
+ gstreamer-dev
+ gtk-doc
+ libxml2-dev
+ meson
+ py3-gobject3-dev
+ python3
+ "
subpackages="$pkgname-dev $pkgname-doc"
source="https://gstreamer.freedesktop.org/src/gst-editing-services/gst-editing-services-$pkgver.tar.xz"
options="!check" # https://gitlab.freedesktop.org/gstreamer/gst-editing-services/-/issues/125
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
+ CPPFLAGS="$CPPFLAGS -O2" \
+ abuild-meson \
+ -Db_lto=true \
+ -Dtests="$(want_check && echo enabled || echo disabled)" \
+ . output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -30,5 +46,5 @@ package() {
}
sha512sums="
-b2107f2c5f1934721dd029c818f09f62a458ddfb0111060afd0fbbd2e8df9814218750ceff800aedac9878d4c5ae0f3f9fc08b8f8e82cadd1aa14b436737dcad gst-editing-services-1.18.5.tar.xz
+87f1240c3c18d1530ace3f15ad50acef90dab2808198658b5f9da54a5cfe2ee2c040e7bdd766550e566c5e86a1509b12a473b6063f3a7e471ee18b163b40873d gst-editing-services-1.22.11.tar.xz
"