aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-bad/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gst-plugins-bad/APKBUILD')
-rw-r--r--community/gst-plugins-bad/APKBUILD144
1 files changed, 106 insertions, 38 deletions
diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
index 23f8a9811b9..16ecf56509f 100644
--- a/community/gst-plugins-bad/APKBUILD
+++ b/community/gst-plugins-bad/APKBUILD
@@ -1,63 +1,131 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-bad
-pkgver=1.16.2
-pkgrel=10
+pkgver=1.22.11
+pkgrel=0
pkgdesc="GStreamer streaming media framework bad plug-ins"
-url="https://gstreamer.freedesktop.org"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
-options="!check" # 3 out of 51 tests fail as of 1.16.0
+options="!check" # 4 out of 51 tests fail as of 1.20.1
replaces="gst-plugins-bad1"
-makedepends="alsa-lib-dev bluez-dev bzip2-dev curl-dev directfb-dev faac-dev
- faad2-dev flite-dev glib-dev glu-dev gsm-dev gst-plugins-base-dev
- gstreamer-dev libass-dev libdc1394-dev libexif-dev libmms-dev
- libmodplug-dev libsrtp-dev libvdpau-dev libwebp-dev libnice-dev
- libx11-dev mesa-dev meson neon-dev openssl-dev opus-dev orc-compiler
- orc-dev spandsp-dev tiff-dev x265-dev vulkan-loader-dev vulkan-headers
- wayland-dev wayland-protocols gobject-introspection-dev libusrsctp-dev
- lcms2-dev pango-dev chromaprint-dev fdk-aac-dev fluidsynth-dev
- libde265-dev openal-soft-dev openexr-dev openjpeg-dev libdvdnav-dev
- libdvdread-dev sbc-dev libsndfile-dev soundtouch-dev libxkbcommon-dev
- zbar-dev gtk+3.0-dev rtmpdump-dev vo-aacenc-dev vo-amrwbenc-dev
-"
+# chromaprint causes a circular dependency:
+# pipewire -> libcamera -> here -> chromaprint -> ffmpeg -> sdl2 -> pipewire
+makedepends="
+ alsa-lib-dev
+ aom-dev
+ bluez-dev
+ bzip2-dev
+ curl-dev
+ directfb-dev
+ faac-dev
+ faad2-dev
+ fdk-aac-dev
+ flite-dev
+ glib-dev
+ glu-dev
+ gobject-introspection-dev
+ gsm-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk+3.0-dev
+ lcms2-dev
+ libass-dev
+ libdc1394-dev
+ libde265-dev
+ libdvdnav-dev
+ libdvdread-dev
+ libexif-dev
+ libfreeaptx-dev
+ libgudev-dev
+ libmms-dev
+ libmodplug-dev
+ libnice-dev
+ librsvg-dev
+ libsndfile-dev
+ libsrtp-dev
+ libusrsctp-dev
+ libva-glx-dev
+ libvdpau-dev
+ libwebp-dev
+ libx11-dev
+ libxkbcommon-dev
+ mesa-dev
+ meson
+ neon-dev
+ openal-soft-dev
+ openexr-dev
+ openh264-dev
+ openjpeg-dev
+ openssl-dev>3
+ opus-dev
+ orc-dev
+ pango-dev
+ rtmpdump-dev
+ sbc-dev
+ soundtouch-dev
+ spandsp-dev
+ tiff-dev
+ vo-aacenc-dev
+ vo-amrwbenc-dev
+ vulkan-headers
+ vulkan-loader-dev
+ wayland-dev
+ wayland-protocols
+ x265-dev
+ zbar-dev
+ "
+subpackages="$pkgname-lang $pkgname-dev"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
+ldpath="/usr/lib/gstreamer-1.0"
case "$CARCH" in
- s390x) ;;
- mips*) ;;
- armv7|armhf) makedepends="$makedepends librsvg-dev" ;;
- *) makedepends="$makedepends librsvg-dev aom-dev" ;;
+s390x)
+ ;;
+*)
+ makedepends="$makedepends libldac-dev"
+ ;;
esac
-subpackages="$pkgname-lang $pkgname-dev"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
-ldpath="/usr/lib/gstreamer-1.0"
+# secfixes:
+# 1.22.9-r0:
+# - CVE-2024-0444
+# 1.22.8-r0:
+# - ZDI-CAN-22300
+# 1.22.7-r0:
+# - CVE-2023-44446
+# - CVE-2023-44429
+# 1.22.6-r0:
+# - CVE-2023-40476
+# - CVE-2023-40475
+# - CVE-2023-40474
+# 1.22.4-r0:
+# - CVE-2023-37329
+# - CVE-2023-37328
build() {
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
+ CPPFLAGS="$CPPFLAGS -O2" \
+ abuild-meson \
+ -Db_lto=true \
-Dpackage-origin="https://alpinelinux.org" \
-Dpackage-name="GStreamer bad plug-ins (Alpine Linux)" \
-Dintrospection=enabled \
- -Dvulkan=enabled \
-Dsctp=enabled \
+ -Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- ninja -C output
+ meson compile -C output
}
check() {
- # XDG_RUNTIME_DIR is just a temporary directory for a user, created
- # by pam_systemd (or in Alpine's case elogind's pam_elogind) mounted at
- # run/user/$(id -u), since we don't run elogind on the builders we can
- # just point it at /tmp
- XDG_RUNTIME_DIR=/tmp meson test -C output --print-errorlogs
+ XDG_RUNTIME_DIR="$(mktemp -d)" \
+ meson test --no-rebuild -C output --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="aeaf3388156fe7317e193a3f940d391a6d8a1187f93e6925cee4cb02c4e78d9b456c22c27c318f0f9b2212ca68887c5cdcc256adaf068bfab8ec5c091a1e8805 gst-plugins-bad-1.16.2.tar.xz"
+sha512sums="
+cf1901b4d4459be253d00bb65fdf6c86920ad4f034d91bd278509dfcb4e1729fdbedc127aebcd4470cc24c841d94e4199ef60747576b881ded6afc6d41985c70 gst-plugins-bad-1.22.11.tar.xz
+"