aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-bad/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gst-plugins-bad/APKBUILD')
-rw-r--r--community/gst-plugins-bad/APKBUILD128
1 files changed, 101 insertions, 27 deletions
diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
index 47d22b4870f..16ecf56509f 100644
--- a/community/gst-plugins-bad/APKBUILD
+++ b/community/gst-plugins-bad/APKBUILD
@@ -1,51 +1,125 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-bad
-pkgver=1.18.5
-pkgrel=2
+pkgver=1.22.11
+pkgrel=0
pkgdesc="GStreamer streaming media framework bad plug-ins"
-url="https://gstreamer.freedesktop.org"
+url="https://gstreamer.freedesktop.org/"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
-options="!check" # 3 out of 51 tests fail as of 1.16.0
+options="!check" # 4 out of 51 tests fail as of 1.20.1
replaces="gst-plugins-bad1"
-makedepends="alsa-lib-dev aom-dev bluez-dev bzip2-dev curl-dev directfb-dev faac-dev
- faad2-dev flite-dev glib-dev glu-dev gsm-dev gst-plugins-base-dev
- gstreamer-dev libass-dev libdc1394-dev libmms-dev libgudev-dev
- libmodplug-dev libsrtp-dev libvdpau-dev libwebp-dev libnice-dev
- libx11-dev mesa-dev meson neon-dev openssl1.1-compat-dev opus-dev orc-compiler
- orc-dev spandsp-dev tiff-dev x265-dev vulkan-loader-dev vulkan-headers
- wayland-dev wayland-protocols gobject-introspection-dev libusrsctp-dev
- lcms2-dev pango-dev chromaprint-dev fdk-aac-dev fluidsynth-dev
- libde265-dev openal-soft-dev openexr-dev openjpeg-dev libdvdnav-dev
- libdvdread-dev sbc-dev libsndfile-dev soundtouch-dev libxkbcommon-dev
- zbar-dev gtk+3.0-dev rtmpdump-dev vo-aacenc-dev vo-amrwbenc-dev
+# chromaprint causes a circular dependency:
+# pipewire -> libcamera -> here -> chromaprint -> ffmpeg -> sdl2 -> pipewire
+makedepends="
+ alsa-lib-dev
+ aom-dev
+ bluez-dev
+ bzip2-dev
+ curl-dev
+ directfb-dev
+ faac-dev
+ faad2-dev
+ fdk-aac-dev
+ flite-dev
+ glib-dev
+ glu-dev
+ gobject-introspection-dev
+ gsm-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk+3.0-dev
+ lcms2-dev
+ libass-dev
+ libdc1394-dev
+ libde265-dev
+ libdvdnav-dev
+ libdvdread-dev
+ libexif-dev
+ libfreeaptx-dev
+ libgudev-dev
+ libmms-dev
+ libmodplug-dev
+ libnice-dev
+ librsvg-dev
+ libsndfile-dev
+ libsrtp-dev
+ libusrsctp-dev
+ libva-glx-dev
+ libvdpau-dev
+ libwebp-dev
+ libx11-dev
+ libxkbcommon-dev
+ mesa-dev
+ meson
+ neon-dev
+ openal-soft-dev
+ openexr-dev
+ openh264-dev
+ openjpeg-dev
+ openssl-dev>3
+ opus-dev
+ orc-dev
+ pango-dev
+ rtmpdump-dev
+ sbc-dev
+ soundtouch-dev
+ spandsp-dev
+ tiff-dev
+ vo-aacenc-dev
+ vo-amrwbenc-dev
+ vulkan-headers
+ vulkan-loader-dev
+ wayland-dev
+ wayland-protocols
+ x265-dev
+ zbar-dev
"
+subpackages="$pkgname-lang $pkgname-dev"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
+ldpath="/usr/lib/gstreamer-1.0"
case "$CARCH" in
- s390x|mips64|riscv64) ;;
- *) makedepends="$makedepends librsvg-dev libexif-dev" ;;
+s390x)
+ ;;
+*)
+ makedepends="$makedepends libldac-dev"
+ ;;
esac
-subpackages="$pkgname-lang $pkgname-dev"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-$pkgver.tar.xz"
-ldpath="/usr/lib/gstreamer-1.0"
+# secfixes:
+# 1.22.9-r0:
+# - CVE-2024-0444
+# 1.22.8-r0:
+# - ZDI-CAN-22300
+# 1.22.7-r0:
+# - CVE-2023-44446
+# - CVE-2023-44429
+# 1.22.6-r0:
+# - CVE-2023-40476
+# - CVE-2023-40475
+# - CVE-2023-40474
+# 1.22.4-r0:
+# - CVE-2023-37329
+# - CVE-2023-37328
build() {
+ CFLAGS="$CFLAGS -O2" \
+ CXXFLAGS="$CXXFLAGS -O2" \
+ CPPFLAGS="$CPPFLAGS -O2" \
abuild-meson \
+ -Db_lto=true \
-Dpackage-origin="https://alpinelinux.org" \
-Dpackage-name="GStreamer bad plug-ins (Alpine Linux)" \
-Dintrospection=enabled \
-Dsctp=enabled \
+ -Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- # XDG_RUNTIME_DIR is just a temporary directory for a user, created
- # by pam_systemd (or in Alpine's case elogind's pam_elogind) mounted at
- # run/user/$(id -u), since we don't run elogind on the builders we can
- # just point it at /tmp
- XDG_RUNTIME_DIR=/tmp meson test -C output --print-errorlogs
+ XDG_RUNTIME_DIR="$(mktemp -d)" \
+ meson test --no-rebuild -C output --print-errorlogs
}
package() {
@@ -53,5 +127,5 @@ package() {
}
sha512sums="
-619c0ac0055b8d1b767924a9ee68a3fd87b197b3587784387a296d2dac8f30fe28d00d2ac3c94968fb71cfccb50ceffa6e2ad86d1857f63f1b05c5780a5c0a20 gst-plugins-bad-1.18.5.tar.xz
+cf1901b4d4459be253d00bb65fdf6c86920ad4f034d91bd278509dfcb4e1729fdbedc127aebcd4470cc24c841d94e4199ef60747576b881ded6afc6d41985c70 gst-plugins-bad-1.22.11.tar.xz
"