aboutsummaryrefslogtreecommitdiffstats
path: root/community/gst-plugins-good/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gst-plugins-good/APKBUILD')
-rw-r--r--community/gst-plugins-good/APKBUILD99
1 files changed, 80 insertions, 19 deletions
diff --git a/community/gst-plugins-good/APKBUILD b/community/gst-plugins-good/APKBUILD
index 4a74706c37a..d5f99cda1fd 100644
--- a/community/gst-plugins-good/APKBUILD
+++ b/community/gst-plugins-good/APKBUILD
@@ -1,33 +1,83 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-good
-pkgver=1.18.5
+pkgver=1.22.11
pkgrel=0
pkgdesc="GStreamer streaming media framework good plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
-subpackages="$pkgname-lang $pkgname-gtk"
-replaces="gst-plugins-good1"
-makedepends="cairo-dev flac-dev gdk-pixbuf-dev glib-dev gst-plugins-base-dev
- gstreamer-dev gtk+3.0-dev jack-dev lame-dev libavc1394-dev libcaca-dev
- libdv-dev libgudev-dev libice-dev libiec61883-dev libjpeg-turbo-dev
- libogg-dev libpng-dev libshout-dev libsm-dev libsoup-dev libvpx-dev
- libxdamage-dev libxext-dev libxv-dev linux-headers meson mpg123-dev
- orc-compiler orc-dev taglib-dev v4l-utils-dev wavpack-dev zlib-dev
- pulseaudio-dev"
+subpackages="$pkgname-lang $pkgname-gtk $pkgname-qt"
+replaces="gst-plugins-good1 gst-plugins-ugly"
+depends="libsoup3"
+makedepends="
+ cairo-dev
+ flac-dev
+ gdk-pixbuf-dev
+ glib-dev
+ gst-plugins-base-dev
+ gstreamer-dev
+ gtk+3.0-dev
+ jack-dev
+ lame-dev
+ libavc1394-dev
+ libdv-dev
+ libgudev-dev
+ libice-dev
+ libiec61883-dev
+ libjpeg-turbo-dev
+ libogg-dev
+ libpng-dev
+ libshout-dev
+ libsm-dev
+ libsoup3-dev
+ libvpx-dev
+ libxdamage-dev
+ libxext-dev
+ libxv-dev
+ linux-headers
+ meson
+ mpg123-dev
+ nasm
+ orc-compiler
+ orc-dev
+ pulseaudio-dev
+ qt5-qtdeclarative-dev
+ qt6-qtwayland-dev
+ qt5-qtx11extras-dev
+ qt6-qtdeclarative-dev
+ qt6-qttools-dev
+ qt6-qtwayland-dev
+ taglib-dev
+ v4l-utils-dev
+ wavpack-dev
+ zlib-dev
+ "
ldpath="/usr/lib/gstreamer-1.0"
-source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz"
-options="!check" # elements/souphttpsrc fails
+source="https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-$pkgver.tar.xz
+ flaky-test.patch
+ tests-fix-memory-corruption.patch
+ "
case "$CARCH" in
- armhf) ;;
- *)
- makedepends="$makedepends qt5-qtdeclarative-dev qt5-qtx11extras-dev"
- subpackages="$subpackages $pkgname-qt"
+armhf|s390x|ppc64le)
+ # really flaky tests
+ options="$options !check"
+ ;;
+*)
;;
esac
# secfixes:
+# 1.22.4-r0:
+# - CVE-2023-37327
+# 1.20.3-r0:
+# - CVE-2022-1920
+# - CVE-2022-1921
+# - CVE-2022-1922
+# - CVE-2022-1923
+# - CVE-2022-1924
+# - CVE-2022-1925
+# - CVE-2022-2122
# 1.18.4-r0:
# - CVE-2021-3497
# - CVE-2021-3498
@@ -43,15 +93,24 @@ esac
# - CVE-2016-10199
build() {
+ # MPG123_NO_LARGENAME: fix undefined reference to
+ # `mpg123_decode_frame_64' in function
+ # `gst_mpg123_audio_dec_handle_frame'
+
+ CFLAGS="$CFLAGS -O2 -DMPG123_NO_LARGENAME" \
+ CXXFLAGS="$CXXFLAGS -O2 -DMPG123_NO_LARGENAME" \
+ CPPFLAGS="$CPPFLAGS -O2 -DMPG123_NO_LARGENAME" \
abuild-meson \
+ -Db_lto=true \
-Dpackage-origin="https://alpinelinux.org" \
-Dpackage-name="GStreamer good plug-ins (Alpine Linux)" \
+ -Dtests="$(want_check && echo enabled || echo disabled)" \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- make check
+ meson test -t 2 --print-errorlogs --no-rebuild -C output
}
package() {
@@ -83,5 +142,7 @@ gtk() {
}
sha512sums="
-c872f3bb1d5e8f1dcc9a226d161299de5113bc20694ef8c6b6d426f536e8b259a1751951fb69c9a7507ad42ef77b91aae9e4f6e957502dc94f48ed023ee70433 gst-plugins-good-1.18.5.tar.xz
+e6105c90a66bfee8a69f621bf44f53fcbf832ec9290cee984354da91e57b61d2bbd548e3ad0c5d9f859d0c3f5ba3c313539f24b350e0a7acf29cb8983d4f40cb gst-plugins-good-1.22.11.tar.xz
+e471a892c511c501fdd336cd1729df4e955e266a395260db50665b4ee717d881a007ae84873c57e386931c042ce08ee8f3ab8e102ba251632f724e167b5af913 flaky-test.patch
+7779f0eee4dda158c88e19e4d0534afd5cdde393d269f88a521cda0f2106afc2a0b386cc7b13242fed8ce7f71e4d9400507e5bef19bc0374eadc81a0a5e3a14b tests-fix-memory-corruption.patch
"