aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtk-layer-shell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtk-layer-shell/APKBUILD')
-rw-r--r--community/gtk-layer-shell/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/gtk-layer-shell/APKBUILD b/community/gtk-layer-shell/APKBUILD
index 4dbd82418ec..9752faa13b0 100644
--- a/community/gtk-layer-shell/APKBUILD
+++ b/community/gtk-layer-shell/APKBUILD
@@ -1,29 +1,31 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=gtk-layer-shell
-pkgver=0.6.0
-pkgrel=2
+pkgver=0.8.2
+pkgrel=0
pkgdesc="Create panels and other desktop components in Wayland using the Layer Shell protocol"
url="https://github.com/wmww/gtk-layer-shell"
arch="all"
license="MIT"
-makedepends="meson wayland-dev gtk+3.0-dev gobject-introspection-dev"
+makedepends="meson wayland-dev gtk+3.0-dev gobject-introspection-dev vala"
+checkdepends="xvfb-run font-dejavu"
subpackages="$pkgname-dev $pkgname-demo"
-source="$pkgname-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/v$pkgver.tar.gz
- disable-warn_gtk_version_may_be_unsupported.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/v$pkgver.tar.gz"
build() {
abuild-meson \
+ -Db_lto=true \
-Dexamples=true \
-Ddocs=false \
-Dtests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ XDG_RUNTIME_DIR="$(mktemp -d -p "$builddir")" \
+ xvfb-run -a \
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -37,6 +39,5 @@ demo() {
}
sha512sums="
-ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523 gtk-layer-shell-0.6.0.tar.gz
-e5219f2ea9ee91933d99b3e825b5223c5cb296672974afcdf24149bf801088fa444aa68828eadf88b1ba16f79641144d344032429e7f899bfbca2433dce083f3 disable-warn_gtk_version_may_be_unsupported.patch
+e3b56612dab2527d5242b8305362c88100de3eac76cee32ce51791cbc77df38a5052143bf4bf5781a90fa62e026a758ef9d10dc5b4292b0b334983842fad632c gtk-layer-shell-0.8.2.tar.gz
"