aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtk-layer-shell/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtk-layer-shell/APKBUILD')
-rw-r--r--community/gtk-layer-shell/APKBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/community/gtk-layer-shell/APKBUILD b/community/gtk-layer-shell/APKBUILD
index df630e6d2a2..9752faa13b0 100644
--- a/community/gtk-layer-shell/APKBUILD
+++ b/community/gtk-layer-shell/APKBUILD
@@ -1,31 +1,43 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=gtk-layer-shell
-pkgver=0.6.0
+pkgver=0.8.2
pkgrel=0
pkgdesc="Create panels and other desktop components in Wayland using the Layer Shell protocol"
url="https://github.com/wmww/gtk-layer-shell"
arch="all"
license="MIT"
-makedepends="meson wayland-dev gtk+3.0-dev gobject-introspection-dev"
-subpackages="$pkgname-dev"
+makedepends="meson wayland-dev gtk+3.0-dev gobject-introspection-dev vala"
+checkdepends="xvfb-run font-dejavu"
+subpackages="$pkgname-dev $pkgname-demo"
source="$pkgname-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/v$pkgver.tar.gz"
build() {
abuild-meson \
- -Dexamples=false \
+ -Db_lto=true \
+ -Dexamples=true \
-Ddocs=false \
-Dtests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ XDG_RUNTIME_DIR="$(mktemp -d -p "$builddir")" \
+ xvfb-run -a \
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="ca5367b5f1637a07c28c772e79e5ac84219ff069091077f83c5edbc88be084538a925b3c76e6cc9dcd8d2826ae340b79605875e87209ee4f4d5e27dc4e93a523 gtk-layer-shell-0.6.0.tar.gz"
+demo() {
+ pkgdesc="Demo of GTK Layer Shell"
+
+ amove usr/bin/gtk-layer-demo
+}
+
+sha512sums="
+e3b56612dab2527d5242b8305362c88100de3eac76cee32ce51791cbc77df38a5052143bf4bf5781a90fa62e026a758ef9d10dc5b4292b0b334983842fad632c gtk-layer-shell-0.8.2.tar.gz
+"