aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtk-vnc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtk-vnc/APKBUILD')
-rw-r--r--community/gtk-vnc/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/gtk-vnc/APKBUILD b/community/gtk-vnc/APKBUILD
index 050f20e02c9..1fd78d7fbcc 100644
--- a/community/gtk-vnc/APKBUILD
+++ b/community/gtk-vnc/APKBUILD
@@ -20,25 +20,20 @@ subpackages="$pkgname-dev gvncviewer $pkgname-lang $pkgname-doc"
build() {
# https://gitlab.gnome.org/GNOME/gtk-vnc/issues/11
- meson \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
-Dwith-vala=true \
-Dwith-coroutine=gthread \
. output
- ninja -C output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- ninja -C output test
+ meson test --no-rebuild -v -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
gvncviewer() {