aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtkmm3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtkmm3/APKBUILD')
-rw-r--r--community/gtkmm3/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/gtkmm3/APKBUILD b/community/gtkmm3/APKBUILD
index ec149f8b9e8..b6c4a94be3f 100644
--- a/community/gtkmm3/APKBUILD
+++ b/community/gtkmm3/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gtkmm3
-pkgver=3.24.4
+pkgver=3.24.9
pkgrel=0
pkgdesc="C++ wrappers for GTK+"
url="https://www.gtkmm.org/"
@@ -23,18 +23,21 @@ builddir="$srcdir/gtkmm-$pkgver"
build() {
abuild-meson \
+ -Db_lto=true \
-Dbuild-demos=false \
-Dbuild-tests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="e3a10aed9cf2df7369b5dac3f1de000b006e08aef6f2d953d2faf2b023bd744ed4c9c2ad5221adc1b0c919bcdc966d0c1c9dc698694d8630ceba56e39f91ac26 gtkmm-3.24.4.tar.xz"
+sha512sums="
+6e6e53d7d434f51758ffddce00dbae61074c54a5d3a5bb852fea558147af4ca6c40f9fcf4e7f9fafcbbc22ea33cdd99ea06208b72542c7e75f4dca19a80c6724 gtkmm-3.24.9.tar.xz
+"