aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtkmm3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtkmm3/APKBUILD')
-rw-r--r--community/gtkmm3/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/gtkmm3/APKBUILD b/community/gtkmm3/APKBUILD
index 829dd187eea..b6c4a94be3f 100644
--- a/community/gtkmm3/APKBUILD
+++ b/community/gtkmm3/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gtkmm3
-pkgver=3.24.5
+pkgver=3.24.9
pkgrel=0
pkgdesc="C++ wrappers for GTK+"
url="https://www.gtkmm.org/"
@@ -23,14 +23,15 @@ builddir="$srcdir/gtkmm-$pkgver"
build() {
abuild-meson \
+ -Db_lto=true \
-Dbuild-demos=false \
-Dbuild-tests=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -38,5 +39,5 @@ package() {
}
sha512sums="
-8cc5aed26cc631123a5b38bc19643cf9e900beb38681b29ead9049f6b8f930f0b8ace317b8290279ab89cad85075dcb66863174082f77a2b67e4d8bd3c29de49 gtkmm-3.24.5.tar.xz
+6e6e53d7d434f51758ffddce00dbae61074c54a5d3a5bb852fea558147af4ca6c40f9fcf4e7f9fafcbbc22ea33cdd99ea06208b72542c7e75f4dca19a80c6724 gtkmm-3.24.9.tar.xz
"