aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtkmm4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtkmm4/APKBUILD')
-rw-r--r--community/gtkmm4/APKBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/community/gtkmm4/APKBUILD b/community/gtkmm4/APKBUILD
index a3738004299..7a80096519f 100644
--- a/community/gtkmm4/APKBUILD
+++ b/community/gtkmm4/APKBUILD
@@ -1,12 +1,11 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gtkmm4
-pkgver=4.2.0
-pkgrel=0
+pkgver=4.10.0
+pkgrel=3
pkgdesc="C++ wrappers for GTK 4"
url="https://www.gtkmm.org/"
-# s390x, mips64 and riscv64 blocked by polkit -> gtk4.0
-arch="all !s390x !mips64 !riscv64"
+arch="all"
license="LGPL-2.1-or-later"
makedepends="
atkmm2.36-dev
@@ -22,8 +21,10 @@ makedepends="
perl
"
checkdepends="xvfb-run"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://download.gnome.org/sources/gtkmm/${pkgver%.*}/gtkmm-$pkgver.tar.xz"
+subpackages="$pkgname-devhelp $pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/gtkmm/${pkgver%.*}/gtkmm-$pkgver.tar.xz
+ setlocale-sigsegv.patch
+ "
builddir="$srcdir/gtkmm-$pkgver"
build() {
@@ -32,11 +33,11 @@ build() {
-Dbuild-tests=true \
-Dbuild-documentation=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run -a meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -44,5 +45,6 @@ package() {
}
sha512sums="
-c4532c427da0a37e4f8ba6f0e6d3975c3f84db461bc08263a4a81e6ee9e750112a2b4b0c5000ba22f8fd4fc5f833ef320f2c1f56580157f7ae41667ff15ccc72 gtkmm-4.2.0.tar.xz
+ee40cce37c34814884ffc06e614013d23fa31cac51ea9d98ea5689a08acc2ff58bb2ca80ba822d6fe3c0f3bdcb9ce2596ede3c05c69a702b524c4e38afc3d9ab gtkmm-4.10.0.tar.xz
+9ae42182f1b7a8bd21b3e1aaaa830222402a685d4b98c12f2480e724afaa98828e5cade8e8fd79a976c5a110f0ebe19f9703f92dc097a4e9b467b6ec773119bd setlocale-sigsegv.patch
"