aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtksourceview4/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gtksourceview4/APKBUILD')
-rw-r--r--community/gtksourceview4/APKBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/gtksourceview4/APKBUILD b/community/gtksourceview4/APKBUILD
index 450b69735a5..1e227b8772a 100644
--- a/community/gtksourceview4/APKBUILD
+++ b/community/gtksourceview4/APKBUILD
@@ -1,16 +1,16 @@
-# Contributor:Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer:
pkgname=gtksourceview4
-pkgver=4.8.1
-pkgrel=1
+pkgver=4.8.4
+pkgrel=4
pkgdesc="A text widget adding syntax highlighting and more to GNOME"
url="https://wiki.gnome.org/Projects/GtkSourceView"
-arch="all !mips64" # blocked by glade -> webkit2gtk
+arch="all"
license="GPL-2.0-or-later"
replaces="gtksourceview"
depends_dev="gtk+3.0-dev libxml2-dev"
-makedepends="$depends_dev gobject-introspection-dev vala libxslt meson glade-dev"
-checkdepends="xvfb-run ibus dbus"
+makedepends="$depends_dev gobject-introspection-dev vala libxslt meson"
+checkdepends="xvfb-run ibus dbus font-liberation"
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/gtksourceview/${pkgver%.*}/gtksourceview-$pkgver.tar.xz
skip-test.patch
@@ -19,17 +19,20 @@ builddir="$srcdir/gtksourceview-$pkgver"
build() {
abuild-meson \
- -Dglade_catalog=true \
+ -Db_lto=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- xvfb-run meson test --no-rebuild -v -C output
+ xvfb-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="fe3bc05e81f881b97a53e6dfb807ded314f1953ebe74424b515d6c1333e72011e3b756b958cca40becad0f66434cf16c56d42fff950b8d643e65c9a03e9cb88b gtksourceview-4.8.1.tar.xz
-c765c7c77a94007e95c050c05ef0283b2cdcd5751274924ea08a02ea2507061677d7f286c3e98d6b91f3603a06364d1ea43491e77e2e086e05c841218923e771 skip-test.patch"
+
+sha512sums="
+9e4262e52a92b3a052f33b799622d4fd4dcc7cc5355df12f160d0e60a6d6c135bc52f07eb40c06b357d5d74bec7228d4ec545a69ee5af69429d4170cc1e2243d gtksourceview-4.8.4.tar.xz
+c765c7c77a94007e95c050c05ef0283b2cdcd5751274924ea08a02ea2507061677d7f286c3e98d6b91f3603a06364d1ea43491e77e2e086e05c841218923e771 skip-test.patch
+"