aboutsummaryrefslogtreecommitdiffstats
path: root/community/gulkan/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gulkan/APKBUILD')
-rw-r--r--community/gulkan/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/gulkan/APKBUILD b/community/gulkan/APKBUILD
index c6b5974f026..503eb207035 100644
--- a/community/gulkan/APKBUILD
+++ b/community/gulkan/APKBUILD
@@ -1,38 +1,41 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=gulkan
-pkgver=0.15.2
-pkgrel=0
+pkgver=0.16.0
+pkgrel=5
pkgdesc="GLib library for Vulkan abstraction"
url="https://gitlab.freedesktop.org/xrdesktop/gulkan"
arch="all"
license="MIT AND CC-BY-SA-4.0"
depends_dev="gobject-introspection-dev"
makedepends="$depends_dev
- cmd:glslangValidator
gdk-pixbuf-dev
+ glslang
graphene-dev
- gtk-doc
+ libdrm-dev
+ libxkbcommon-dev
meson
vulkan-loader-dev
"
source="https://gitlab.freedesktop.org/xrdesktop/gulkan/-/archive/$pkgver/gulkan-$pkgver.tar.gz"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-libs $pkgname-dev"
options="!check" # Requires a working Vulkan driver
build() {
abuild-meson \
- -Dapi_doc=true \
+ -Dapi_doc=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="abddaa6c40ad260e52bca06377c37b8bac5a3ee884374df076de9903c1a6e946e1b9f8f5a794a629025c88b4fe19cf5ae0b2cc8570e696741173a89a2a98ef57 gulkan-0.15.2.tar.gz"
+sha512sums="
+b05441ab8569845a6031ce4779ba3c68e06a184feb0886def3abbde521ef63df8e91c4e92102316a1a46427073dcac9ff95aca19b769b7dc2d0fc2e8a562385c gulkan-0.16.0.tar.gz
+"