aboutsummaryrefslogtreecommitdiffstats
path: root/community/gvfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gvfs/APKBUILD')
-rw-r--r--community/gvfs/APKBUILD56
1 files changed, 41 insertions, 15 deletions
diff --git a/community/gvfs/APKBUILD b/community/gvfs/APKBUILD
index d144389cf76..b99d8b6f01a 100644
--- a/community/gvfs/APKBUILD
+++ b/community/gvfs/APKBUILD
@@ -1,22 +1,47 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: team/gnome <ablocorrea@hotmail.com>
pkgname=gvfs
-pkgver=1.50.1
+pkgver=1.52.1
pkgrel=0
pkgdesc="Backends for the gio framework in GLib"
url="https://wiki.gnome.org/Projects/gvfs"
-# s390x and riscv64 blocked by polkit -> udisks2
-arch="all !s390x !riscv64"
+arch="all"
license="LGPL-2.0-or-later"
depends="gsettings-desktop-schemas dbus:org.freedesktop.Secrets"
-makedepends="fuse3-dev libgudev-dev expat-dev samba-dev libxml2-dev
- libsoup3-dev avahi-dev libarchive-dev udisks2-dev libgphoto2-dev
- libcdio-paranoia-dev libgcrypt-dev libxslt-dev docbook-xsl
- libmtp-dev gcr-dev libcap-dev libsecret-dev libnfs-dev meson
- openssh-client libusb-dev gnome-online-accounts-dev libimobiledevice-dev
- libbluray-dev libgdata-dev gsettings-desktop-schemas-dev"
+makedepends="
+ avahi-dev
+ docbook-xsl
+ expat-dev
+ fuse3-dev
+ gcr-dev
+ gnome-online-accounts-dev
+ gsettings-desktop-schemas-dev
+ libarchive-dev
+ libbluray-dev
+ libcap-dev
+ libcdio-paranoia-dev
+ libgcrypt-dev
+ libgdata-dev
+ libgphoto2-dev
+ libgudev-dev
+ libimobiledevice-dev
+ libmtp-dev
+ libnfs-dev
+ libsecret-dev
+ libsoup3-dev
+ libusb-dev
+ libxml2-dev
+ libxslt-dev
+ meson
+ openssh-client
+ samba-dev
+ udisks2-dev
+ "
triggers="$pkgname.trigger=/usr/libexec/gvfs"
-subpackages="$pkgname-dev $pkgname-lang
+subpackages="
+ $pkgname-dbg
+ $pkgname-dev
+ $pkgname-lang
$pkgname-afc
$pkgname-afp
$pkgname-archive
@@ -41,18 +66,18 @@ source="https://download.gnome.org/sources/gvfs/${pkgver%.*}/gvfs-$pkgver.tar.xz
build() {
abuild-meson \
+ -Db_lto=true \
--libexecdir=/usr/libexec/gvfs \
-Dsystemduserunitdir=no \
-Dtmpfilesdir=no \
-Dlogind=false \
. output
-
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -156,6 +181,7 @@ afc() {
usr/share/dbus-1/services/org.gtk.vfs.AfcVolumeMonitor.service \
usr/share/gvfs/remote-volume-monitors/afc.monitor
}
+
sha512sums="
-7a1ea47658dbd74673e1aea7c344d3f9e8a26fab844a26220cedcb19da6b4a0cac6b369d2b5107f649d6e7b2331894c89df04c6dce3630be4b289e23f56127a5 gvfs-1.50.1.tar.xz
+7d791afd505bcdbc38e811630a60e846f8980db1e80a07877aa20439177fc9a5def35f4dabd83323a4867a1cce548600e2f6c8bed586ee1ca55f514022e86064 gvfs-1.52.1.tar.xz
"