aboutsummaryrefslogtreecommitdiffstats
path: root/community/gvm-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gvm-tools/APKBUILD')
-rw-r--r--community/gvm-tools/APKBUILD27
1 files changed, 17 insertions, 10 deletions
diff --git a/community/gvm-tools/APKBUILD b/community/gvm-tools/APKBUILD
index 6ef2a921251..4e0294173ce 100644
--- a/community/gvm-tools/APKBUILD
+++ b/community/gvm-tools/APKBUILD
@@ -1,32 +1,39 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gvm-tools
-pkgver=21.10.0
-pkgrel=2
+# follow the same version of py3-gvm
+pkgver=24.1.0
+pkgrel=1
pkgdesc="Collection of tools for remote controlling a OpenVAS / Greenbone"
url="https://github.com/greenbone/gvm-tools"
arch="noarch"
-license="GPL"
-depends="python3 py3-dialog py3-defusedxml py3-paramiko py3-lxml"
-makedepends="py3-build py3-installer py3-poetry-core py3-wheel"
+license="GPL-3.0-or-later"
+depends="python3 py3-gvm py3-lxml"
+makedepends="py3-gpep517 py3-installer py3-poetry-core py3-wheel"
checkdepends="py3-gvm py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gvm-tools/archive/v$pkgver.tar.gz"
build() {
- # XXX: hack for poetry to not ignore files
- GIT_DIR=. python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
# outdated snapshot compare
- python3 -m pytest --ignore tests/test_parser.py
+ .testenv/bin/python3 -m pytest --ignore tests/test_parser.py
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/gvm_tools-$pkgver-py3-none-any.whl
+ .dist/*.whl
+ mkdir -p "$pkgdir"/usr/share/$pkgname/scripts
+ cp $builddir/scripts/*.py "$pkgdir"/usr/share/$pkgname/scripts/
}
sha512sums="
-0dc202debaae1431194585575d11b1af6aa057456429dc46e7bf6677b2217fd8569572dc71b8ada578caa961ff2b371a364fb67277c40e76e3025b6b3fcb3a5b gvm-tools-21.10.0.tar.gz
+6138c6c85421c7b011b73c2c857e9481cd46622ad3627a8d85c50563ebbd3c6d5cae80f43118ec85ef243fb965dcbe1cd7c1df29326f1d81b21c56ad117bef28 gvm-tools-24.1.0.tar.gz
"