aboutsummaryrefslogtreecommitdiffstats
path: root/community/gwenhywfar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gwenhywfar/APKBUILD')
-rw-r--r--community/gwenhywfar/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/gwenhywfar/APKBUILD b/community/gwenhywfar/APKBUILD
index d4b3810940c..0b6f705e8e8 100644
--- a/community/gwenhywfar/APKBUILD
+++ b/community/gwenhywfar/APKBUILD
@@ -1,26 +1,32 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=gwenhywfar
-pkgver=5.7.3
+pkgver=5.10.2
pkgrel=0
pkgdesc="Multi-platform helper library"
url="https://www.aquamaniac.de/"
arch="all"
license="LGPL-2.1-or-later"
-makedepends="libgcrypt-dev gnutls-dev gettext-dev
- automake autoconf libtool bash"
+makedepends="libgcrypt-dev gnutls-dev gettext-dev"
options="net" # tests send HTTP requests to remote hosts
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://www.aquamaniac.de/rdm/attachments/download/390/gwenhywfar-$pkgver.tar.gz
- libintl.patch
+source="https://www.aquamaniac.de/rdm/attachments/download/501/gwenhywfar-$pkgver.tar.gz
fix-tests.patch"
+case "$CARCH" in
+arm*|aarch64)
+ # these tests seem to require ipv4 networking
+ options="$options !check"
+ ;;
+esac
+
prepare() {
default_prepare
- autoreconf -vfi
+ update_config_sub
}
build() {
+ export LDFLAGS="$LDFLAGS -lintl"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -47,7 +53,6 @@ package() {
}
sha512sums="
-c005c0af36786a000cf317647440304f6779b531256cdbd5d67180b7b0b2056c230391a3845057d6061875c505f88f9f23fe086dc7e8a04d35fed33c61a0fb47 gwenhywfar-5.7.3.tar.gz
-fcccf5aa3872f4327205c3c77c5e1b88fbce89d6fe45330f72a38c207b7f6166ca486e70636119a9c16447a3c09e3bad97ed7a1cc5f06db53939f510e2c19cca libintl.patch
-c877b91cd7e680f27b416563df67bf4834064672a021031d31bb597214b362068610de89d05ec2dc44336f02090546b9e6b80ea3758c8bf3974e8be7d5b4971d fix-tests.patch
+d7e414fbf5762dbbb5664d56110d2b41fb693de93b52757ded8b2b883faa73d8d81c1ea033872b7b7928c2849a7373a344613321a8689cc51a8e533cc805f0bf gwenhywfar-5.10.2.tar.gz
+337836a5b6edf1f127768b1654d2e0667d8adc8e02f09a9d7bf0850ecee5fbe2ae544eb6a37436f57708b80c0b919d19f538fda30232ff3ac7c46e448a9adda6 fix-tests.patch
"