aboutsummaryrefslogtreecommitdiffstats
path: root/community/gwsocket/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/gwsocket/APKBUILD')
-rw-r--r--community/gwsocket/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/gwsocket/APKBUILD b/community/gwsocket/APKBUILD
index 0580e022534..9134aec09a7 100644
--- a/community/gwsocket/APKBUILD
+++ b/community/gwsocket/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=gwsocket
-pkgver=0.3
+pkgver=0.4
pkgrel=0
pkgdesc="A simple, standalone, language-agnostic, RFC6455 compliant WebSocket Server"
url="http://gwsocket.io"
@@ -10,17 +10,14 @@ license="MIT"
makedepends="autoconf automake"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/allinurl/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
autoreconf -fiv
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,13 +29,14 @@ build() {
}
check() {
- cd "$builddir"
- ./gwsocket --version > /dev/null
+ local ver_output=$(./gwsocket --version || true)
+ [ "$ver_output" = "GWSocket $pkgver" ]
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="397b10ec22631033e718236bfa5ef297ded6eef5241a8be74fd41495b3d25b5fd31a1cac5389de461bcc61b5cf4da599915608ddd93f7ea788f21b032977520d gwsocket-0.3.tar.gz"
+sha512sums="
+f82085b11fc87598b5f766de19b350ccf5905c70de894d6e2d33346456a1afa6a3ff1dd108e4edbefafbcddfc75dd4c79a099caffa9adfd8311ebee1baafb491 gwsocket-0.4.tar.gz
+"