aboutsummaryrefslogtreecommitdiffstats
path: root/community/happy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/happy/APKBUILD')
-rw-r--r--community/happy/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/community/happy/APKBUILD b/community/happy/APKBUILD
index 7ad98f71a59..1e85ffbf2ef 100644
--- a/community/happy/APKBUILD
+++ b/community/happy/APKBUILD
@@ -1,25 +1,27 @@
# Contributor: River Dillon <oss@outerpassage.net>
# Maintainer: River Dillon <oss@outerpassage.net>
pkgname=happy
-pkgver=1.20.0
-pkgrel=2
+pkgver=1.21.0
+pkgrel=1
pkgdesc="parser generator for Haskell"
url="https://www.haskell.org/happy/"
-arch="x86_64" # limited by ghc
+arch="x86_64 aarch64" # limited by ghc
license="BSD-2-Clause"
makedepends="ghc libffi-dev"
-subpackages="$pkgname-doc"
+[ "$CARCH" = "aarch64" ] && options="!check" # tests broken on aarch64 due to https://github.com/llvm/llvm-project/issues/52844
source="
https://hackage.haskell.org/package/happy-$pkgver/happy-$pkgver.tar.gz
- https://www.haskell.org/happy/doc/happy-1.18.5-html.tar.gz
"
build() {
+ # ghc version path
+ export PATH="$PATH:/usr/lib/llvm14/bin"
runhaskell Setup.hs configure \
"--prefix=/usr" \
"--datasubdir=$pkgname" \
"--docdir=\$datadir/doc/$pkgname" \
- "--enable-tests"
+ "--enable-tests" \
+ -f -bootstrap
runhaskell Setup.hs build -j "--ghc-options=-j -O1"
}
@@ -29,10 +31,8 @@ check() {
package() {
runhaskell Setup.hs copy "--destdir=$pkgdir"
- docdir="usr/share/doc/$pkgname"
- rm "$pkgdir/$docdir/LICENSE" # no need to include a standard license
- install -Dm644 -t "$pkgdir/$docdir/html/" "$srcdir/$pkgname"/*
}
-sha512sums="2c19e6e13032ead435495aab232192cf0ad9fe5e3e04c79b40b586272fb0208284815cf5c15d609f75387e7fe91ca0932b675bcaa95552f62ad08a12701649ce happy-1.20.0.tar.gz
-10d7e5b7c1fd6b60569c0eccbb148d8395eb5c479dc5c124e2de196872c11ae5e8af4d1d55ea24ed7eae35af27b16772468512f3fda4f571eefdce6639747871 happy-1.18.5-html.tar.gz"
+sha512sums="
+d63e33fe958865c560eed01e54f3384d09b6b2b2282480db302366492d18a7fd67f530d92206f8ff19e0842942f608a8d226ea66cd947583c78e800f6d580fec happy-1.21.0.tar.gz
+"