aboutsummaryrefslogtreecommitdiffstats
path: root/community/harec/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/harec/APKBUILD')
-rw-r--r--community/harec/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/harec/APKBUILD b/community/harec/APKBUILD
new file mode 100644
index 00000000000..f8faa402d9c
--- /dev/null
+++ b/community/harec/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Simon Zeni <simon@bl4ckb0ne.ca>
+pkgname=harec
+pkgver=0.24.0
+pkgrel=0
+pkgdesc="The Hare compiler"
+url="https://harelang.org"
+arch="x86_64 aarch64 riscv64"
+license="GPL-3.0-only"
+depends="qbe"
+source="
+ $pkgname-$pkgver.tar.gz::https://git.sr.ht/~sircmpwn/harec/archive/$pkgver.tar.gz
+"
+
+build() {
+ cp configs/linux.mk ./config.mk
+ make PREFIX=/usr ARCH=$CARCH
+}
+
+check() {
+ make ARCH=$CARCH check
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+aab347351bcd748a98e3a58f1ff9a0d194aea907d6ebfacbc7e10671e018fb5ce296e71119ab975e3a1e66ba439d7b706943082d57af2459e694856a89453d8d harec-0.24.0.tar.gz
+"