aboutsummaryrefslogtreecommitdiffstats
path: root/community/haruna/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/haruna/APKBUILD')
-rw-r--r--community/haruna/APKBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/community/haruna/APKBUILD b/community/haruna/APKBUILD
index 0151efe616d..2887741818d 100644
--- a/community/haruna/APKBUILD
+++ b/community/haruna/APKBUILD
@@ -1,24 +1,25 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-other
pkgname=haruna
-pkgver=0.7.3
+pkgver=1.0.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://invent.kde.org/multimedia/haruna"
pkgdesc="Open-source video player built with Qt/QML and libmpv"
license="GPL-2.0-or-later AND GPL-3.0-or-later AND BSD-3-Clause"
depends="
- kirigami2
+ kirigami
yt-dlp
"
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
- qt5-qtquickcontrols2-dev
- mpv-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ mpvqt-dev
ffmpeg-dev
breeze-dev
kconfig-dev
@@ -28,23 +29,25 @@ makedepends="
ki18n-dev
kiconthemes-dev
kio-dev
- kirigami2-dev
+ kirigami-dev
kxmlgui-dev
+ samurai
"
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/multimedia/haruna.git"
source="https://download.kde.org/stable/haruna/haruna-$pkgver.tar.xz"
-subpackages="$pkgname-doc $pkgname-lang"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DBUILD_WITH_QT6=ON \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -52,5 +55,5 @@ package() {
}
sha512sums="
-b3167ab2e85a2e1f804f9d5d9bd7e035bfae28368accce35e143d7af3fec6d76f5e5a6abed969907674141e4b09d10d39564eae1a8339d125f4736d7ef237941 haruna-0.7.3.tar.xz
+d87b4ac8dc4ad0d63d9e3941e7f9c9bae5a2678f8b25711e98d29440a9ea295a949c8005dd94077363340156ba550144984cb81051f69d3995bbf593883a14f5 haruna-1.0.2.tar.xz
"