aboutsummaryrefslogtreecommitdiffstats
path: root/community/herbstluftwm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/herbstluftwm/APKBUILD')
-rw-r--r--community/herbstluftwm/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/herbstluftwm/APKBUILD b/community/herbstluftwm/APKBUILD
index 6d6c973db71..79dfc95f642 100644
--- a/community/herbstluftwm/APKBUILD
+++ b/community/herbstluftwm/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer: prspkt <prspkt@protonmail.com>
pkgname=herbstluftwm
-pkgver=0.9.4
-pkgrel=1
+pkgver=0.9.5
+pkgrel=3
pkgdesc="Manual tiling window manager"
url="https://herbstluftwm.org"
arch="all"
@@ -25,7 +25,7 @@ subpackages="$pkgname-doc
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
- py3-$pkgname:python_bindings
+ py3-$pkgname:python_bindings:noarch
"
source="https://herbstluftwm.org/tarballs/herbstluftwm-$pkgver.tar.gz"
@@ -34,7 +34,7 @@ build() {
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBASHCOMPLETIONDIR=/usr/share/bash-completion/completions \
- -DFISHCOMPLETIONDIR=/usr/share/fish/completions \
+ -DFISHCOMPLETIONDIR=/usr/share/fish/vendor_completions.d \
-DZSHCOMPLETIONDIR=/usr/share/zsh/site-functions
cmake --build build
@@ -44,16 +44,17 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
+ cd python
+ python3 setup.py install --skip-build --root="$pkgdir"
}
python_bindings() {
pkgdesc="Python bindings for herbstluftwm"
depends="python3"
- cd "$builddir"/python
- python3 setup.py install --prefix=/usr --root="$subpkgdir"
+ amove usr/lib/python3*
}
sha512sums="
-068438d14b0addcd17a0c0bda1d33ec4aaff08a3c85698a49e9d3dd0c07f91e315f936d73c11b0c159b8735373ea1efe8a572a0976fc327f4aaa6a0f08436e9d herbstluftwm-0.9.4.tar.gz
+a85fd1ab16b873f512d6965cc4a93524e3ed4a15079d0d4ee54012e217bd41db3b54729c1b30ee361c34b38799f95bc537099056ba7a5f791bf2be6724bc92c3 herbstluftwm-0.9.5.tar.gz
"