aboutsummaryrefslogtreecommitdiffstats
path: root/community/hexchat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hexchat/APKBUILD')
-rw-r--r--community/hexchat/APKBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/community/hexchat/APKBUILD b/community/hexchat/APKBUILD
index e7b703a6deb..473fd0c8c41 100644
--- a/community/hexchat/APKBUILD
+++ b/community/hexchat/APKBUILD
@@ -1,18 +1,31 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hexchat
-pkgver=2.16.0
-pkgrel=0
+pkgver=2.16.2
+pkgrel=1
pkgdesc="Graphical IRC client based on XChat"
url="https://hexchat.github.io"
-arch="all !armhf !armv7"
+arch="all"
license="GPL-2.0-or-later"
-makedepends="dbus-glib-dev gtk+2.0-dev iso-codes libnotify-dev libproxy-dev
- openssl1.1-compat-dev libsexy-dev libxml2-dev lua5.4-dev meson python3-dev
- py3-cffi"
+makedepends="
+ dbus-glib-dev
+ gtk+2.0-dev
+ iso-codes-dev
+ libnotify-dev
+ libproxy-dev
+ libsexy-dev
+ libxml2-dev
+ lua5.4-dev
+ meson
+ openssl-dev>3
+ py3-cffi
+ py3-setuptools
+ python3-dev
+ "
subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
-source="https://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz
+source="https://github.com/hexchat/hexchat/releases/download/v$pkgver/hexchat-$pkgver.tar.xz
force-meson-build-order.patch
"
+options="!check" # No test suite
build() {
abuild-meson \
@@ -21,7 +34,7 @@ build() {
-Dwith-sysinfo=false \
-Dwith-python=python3-embed \
build_dir/
- meson compile ${JOBS:+-j ${JOBS}} -C build_dir/
+ meson compile -C build_dir/
}
package() {
@@ -34,12 +47,12 @@ package() {
_python() {
pkgdesc="Python plugin for hexchat"
- mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
- mv "$pkgdir"/usr/lib/hexchat/plugins/python.so \
- "$subpkgdir"/usr/lib/hexchat/plugins
+ depends="$pkgname=$pkgver-r$pkgrel py3-cffi"
+ amove usr/lib/hexchat/plugins/python.so
+ amove usr/lib/hexchat/python
}
sha512sums="
-4802f6efe0883f48d3d56ee949be1fc224b76a3c76956dcba3f913679e91424ba53c5c0d68bb4e0e790b16a08689111098958ead4c83c35cddf39855fe07c207 hexchat-2.16.0.tar.xz
+2ceb4332328c4acf55a46bf5c45788a7f3a73fd2ffd676751c75cc08ca04ced5569c1e6406877e6f2972b8967e94bea2ad70a6966ade7cd811b5c4d700409ee2 hexchat-2.16.2.tar.xz
f579622330391fbce798bf9b0e5c1d07975a188b79f7160ab8c921b7df92b2d31444f30d6f62b7b08f7543a4ef40975ecf53705903374b73069bb369967491c5 force-meson-build-order.patch
"