aboutsummaryrefslogtreecommitdiffstats
path: root/community/hexchat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hexchat/APKBUILD')
-rw-r--r--community/hexchat/APKBUILD41
1 files changed, 27 insertions, 14 deletions
diff --git a/community/hexchat/APKBUILD b/community/hexchat/APKBUILD
index 2ee093f0c6a..473fd0c8c41 100644
--- a/community/hexchat/APKBUILD
+++ b/community/hexchat/APKBUILD
@@ -1,28 +1,40 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=hexchat
-pkgver=2.14.3
-pkgrel=6
+pkgver=2.16.2
+pkgrel=1
pkgdesc="Graphical IRC client based on XChat"
url="https://hexchat.github.io"
-arch="all !armhf !armv7"
+arch="all"
license="GPL-2.0-or-later"
-makedepends="dbus-glib-dev gtk+2.0-dev iso-codes libnotify-dev libproxy-dev
- openssl1.1-compat-dev libsexy-dev libxml2-dev lua5.4-dev meson python3-dev"
+makedepends="
+ dbus-glib-dev
+ gtk+2.0-dev
+ iso-codes-dev
+ libnotify-dev
+ libproxy-dev
+ libsexy-dev
+ libxml2-dev
+ lua5.4-dev
+ meson
+ openssl-dev>3
+ py3-cffi
+ py3-setuptools
+ python3-dev
+ "
subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
-source="https://dl.hexchat.net/hexchat/hexchat-$pkgver.tar.xz
+source="https://github.com/hexchat/hexchat/releases/download/v$pkgver/hexchat-$pkgver.tar.xz
force-meson-build-order.patch
- fix-lua-5.4.3.patch
"
+options="!check" # No test suite
build() {
abuild-meson \
-Dwith-perl=false \
-Dwith-lua=lua5.4 \
-Dwith-sysinfo=false \
- -Dwith-libcanberra=false \
-Dwith-python=python3-embed \
build_dir/
- meson compile ${JOBS:+-j ${JOBS}} -C build_dir/
+ meson compile -C build_dir/
}
package() {
@@ -35,11 +47,12 @@ package() {
_python() {
pkgdesc="Python plugin for hexchat"
- mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
- mv "$pkgdir"/usr/lib/hexchat/plugins/python.so \
- "$subpkgdir"/usr/lib/hexchat/plugins
+ depends="$pkgname=$pkgver-r$pkgrel py3-cffi"
+ amove usr/lib/hexchat/plugins/python.so
+ amove usr/lib/hexchat/python
}
-sha512sums="c265921f2cb02c5d273bcdbb20a44a5c9f38b0f8cbba4fd56b177b676fc5d1dfd05bf80fcfa3706c7981f712f2f6c9aaaf80bccf3be0f6d96068dd393f3a7cb5 hexchat-2.14.3.tar.xz
+sha512sums="
+2ceb4332328c4acf55a46bf5c45788a7f3a73fd2ffd676751c75cc08ca04ced5569c1e6406877e6f2972b8967e94bea2ad70a6966ade7cd811b5c4d700409ee2 hexchat-2.16.2.tar.xz
f579622330391fbce798bf9b0e5c1d07975a188b79f7160ab8c921b7df92b2d31444f30d6f62b7b08f7543a4ef40975ecf53705903374b73069bb369967491c5 force-meson-build-order.patch
-0837f8e59636c7b3be507ca764030e4fc74071938fbaa4ea8ca9a10c030aa094916f19d0df48fd32c92baef0fc9d2fea835f570f55c79797b791dbf16d5d4d5f fix-lua-5.4.3.patch"
+"