aboutsummaryrefslogtreecommitdiffstats
path: root/community/hexyl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hexyl/APKBUILD')
-rw-r--r--community/hexyl/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/hexyl/APKBUILD b/community/hexyl/APKBUILD
index 7dd93323510..73c668f28a4 100644
--- a/community/hexyl/APKBUILD
+++ b/community/hexyl/APKBUILD
@@ -1,27 +1,34 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=hexyl
-pkgver=0.9.0
+pkgver=0.14.0
pkgrel=0
pkgdesc="Command-line hex viewer with colored output"
url="https://github.com/sharkdp/hexyl"
-license="Apache-2.0 OR MIT"
-arch="all !s390x !mips64 !riscv64" # blocked by rust/cargo
-makedepends="cargo"
+license="MIT OR Apache-2.0"
+arch="all"
+makedepends="cargo cargo-auditable"
source="https://github.com/sharkdp/hexyl/archive/v$pkgver/hexyl-$pkgver.tar.gz"
+options="net" # fetch dependencies
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
build() {
- cargo build --release --locked
+ cargo auditable build --frozen --release
}
check() {
- cargo test --release --locked
+ cargo test --frozen
}
package() {
- install -Dm755 target/release/hexyl "$pkgdir"/usr/bin/hexyl
+ install -Dm755 target/release/$pkgname -t "$pkgdir"/usr/bin/
}
sha512sums="
-a6fc8315dd115ac4b3e3717ffc6e218bf587749149405250796a435834252382fe51c613688729d7de6911340bf6f2002ae945c0f19b499dacc767e995958ce6 hexyl-0.9.0.tar.gz
+770fe3db1fc10ba78cde00d727cf0494d0447e08e1e1f103bd206475c839d4d04c714b5257a3c42d2e489ce02e0b4b9b2701fb89ca9222830c87ccaa2fc8463c hexyl-0.14.0.tar.gz
"