aboutsummaryrefslogtreecommitdiffstats
path: root/community/hhpc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hhpc/APKBUILD')
-rw-r--r--community/hhpc/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/hhpc/APKBUILD b/community/hhpc/APKBUILD
index 7dd02fa6f3b..539a83c7b8b 100644
--- a/community/hhpc/APKBUILD
+++ b/community/hhpc/APKBUILD
@@ -1,27 +1,22 @@
# Contributor: 7heo <7heo@mail.com>
-# Maintainer: 7heo <7heo@mail.com>
+# Maintainer:
pkgname=hhpc
pkgver=0.3.2
-pkgrel=0
+pkgrel=3
pkgdesc="An utility to automatically hide the mouse pointer after a specified delay of inactivity"
url="https://github.com/aktau/hhpc"
arch="all"
-license="BSD"
-depends=""
+license="BSD-3-Clause"
+options="!check" # no test suite
makedepends="libx11-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/7heo/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/7heo/hhpc/archive/v$pkgver.tar.gz"
build() {
- cd "$builddir"
- make || return 1
+ make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="2d579207ce5d6b3fbbfa4b81109ffaa3 hhpc-0.3.2.tar.gz"
-sha256sums="7701e20143133317d0746b6f723bdd9bff92fb7c4bd9af745e632444dbbc3afa hhpc-0.3.2.tar.gz"
sha512sums="c07a054c1826cff530f27c047e52bc982bfe057fa5c92dfd3af42750b4aa8369c614529b62e701c5f9199749659f47e3c56bcbc68b14a0b86b35c9a031d80417 hhpc-0.3.2.tar.gz"