aboutsummaryrefslogtreecommitdiffstats
path: root/community/hhpc
diff options
context:
space:
mode:
Diffstat (limited to 'community/hhpc')
-rw-r--r--community/hhpc/APKBUILD24
1 files changed, 6 insertions, 18 deletions
diff --git a/community/hhpc/APKBUILD b/community/hhpc/APKBUILD
index d435c530984..7dd02fa6f3b 100644
--- a/community/hhpc/APKBUILD
+++ b/community/hhpc/APKBUILD
@@ -6,31 +6,19 @@ pkgrel=0
pkgdesc="An utility to automatically hide the mouse pointer after a specified delay of inactivity"
url="https://github.com/aktau/hhpc"
arch="all"
-license="3-clause BSD"
+license="BSD"
depends=""
-depends_dev=""
-makedepends="$depends_dev libx11-dev"
-install=""
-subpackages=""
-source="hhpc-$pkgver.tar.gz::https://github.com/7heo/hhpc/archive/v$pkgver.tar.gz"
-_builddir="$srcdir"/hhpc-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+makedepends="libx11-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/7heo/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}