aboutsummaryrefslogtreecommitdiffstats
path: root/community/hitch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hitch/APKBUILD')
-rw-r--r--community/hitch/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/hitch/APKBUILD b/community/hitch/APKBUILD
index 80b7932facf..fd3dcaad03c 100644
--- a/community/hitch/APKBUILD
+++ b/community/hitch/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Raphael Cohn <raphael.cohn@stormmq.com>
# Contributor: prez <prez@national.shitposting.agency>
-# Maintainer: Raphael Cohn <raphael.cohn@stormmq.com>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=hitch
-pkgver=1.7.2
-pkgrel=0
+pkgver=1.8.0
+pkgrel=1
pkgdesc="hitch is a TLS / SSL endpoint like stunnel"
url="https://hitch-tls.org/"
arch="all"
-license="BSD-2-Clause"
-makedepends="libev-dev openssl1.1-compat-dev py3-docutils bison flex"
+license="BSD-2-Clause-Views"
+makedepends="libev-dev openssl-dev>3 py3-docutils bison flex"
+checkdepends="grep"
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-openrc"
source="https://hitch-tls.org/source/hitch-$pkgver.tar.gz
@@ -29,6 +30,13 @@ build() {
make
}
+check() {
+ printf '#!/bin/sh\n. hitch_test.sh\nskip "TODO"\n' \
+ > src/tests/test39-client-cert-proxy.sh
+
+ make check
+}
+
package() {
make DESTDIR="$pkgdir" install
@@ -36,13 +44,12 @@ package() {
install -Dm644 "$srcdir/$pkgname.confd" "$pkgdir/etc/conf.d/$pkgname"
install -Dm644 "$srcdir/$pkgname.conf" "$pkgdir/etc/$pkgname/hitch.conf"
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
- install -m644 hitch.conf.example \
- "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -Dm644 hitch.conf.example \
+ -t "$pkgdir"/usr/share/doc/$pkgname/examples
}
sha512sums="
-7b35b5f4a3b6dab2599643c0bc90880a77ea518a627b31813f45a7ee8c52982ba4ac07228b640a0bcf90ea7d63421b62884a091fed6664732585585e5ec15bcf hitch-1.7.2.tar.gz
+62b3554d668c9d17382415db10898bf661ee76343e4ee364f904457efda6cb1eeee7cb81d7a3897734024812b64b1c0e2dc305605706d81a0c1f6030508bf7e2 hitch-1.8.0.tar.gz
afc98a8422199c1c64eeab10e718b71af419f5d4bad692d1e23f539f75d6dcb5efe6dbee21517854254a57075ad8273760602f5cb2f0dbcd00fa1d877ea4ce63 hitch.initd
fee3910d0a3d5b6b34712bfc9a4f56ae316c974ea28991ca2466ed372802e564eee82f6e8af87e73597f66a8f1d2bc0e1a303164e1db51ce90c4bbb68ea6f2da hitch.confd
c2db10a0fec44958f9e3056b013743b4f6c4d0aa21e030120bf7e2f9a3941e276ca1f85ab2a1c051ac17aacd857cae13f308f4d192edc61b2322ab9dbe99f99c hitch.conf