aboutsummaryrefslogtreecommitdiffstats
path: root/community/hr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hr/APKBUILD')
-rw-r--r--community/hr/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/hr/APKBUILD b/community/hr/APKBUILD
new file mode 100644
index 00000000000..7a341361745
--- /dev/null
+++ b/community/hr/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Grigory Kirillov <txgk@bk.ru>
+# Maintainer:
+pkgname=hr
+pkgver=1.4
+pkgrel=1
+pkgdesc="Script that prints characters in the entire width of the terminal"
+url="https://github.com/LuRsT/hr"
+arch="noarch"
+license="MIT"
+options="!check" # no test suite
+depends="
+ bash
+ ncurses
+ "
+subpackages="$pkgname-doc"
+source="https://github.com/LuRsT/hr/archive/$pkgver/hr-$pkgver.tar.gz"
+
+package() {
+ install -Dm755 hr -t "$pkgdir"/usr/bin/
+ install -Dm644 hr.1 -t "$pkgdir"/usr/share/man/man1/
+}
+
+sha512sums="
+bfe77f5197ca50c90b421a2fbe52c0919588ad38d46cc6b460df70473e6d7fbc49f1d4c4602318df4c9b10cd00199d2c720f9cd3268932861f5cc20c6aefabda hr-1.4.tar.gz
+"