aboutsummaryrefslogtreecommitdiffstats
path: root/community/html-xml-utils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/html-xml-utils/APKBUILD')
-rw-r--r--community/html-xml-utils/APKBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/community/html-xml-utils/APKBUILD b/community/html-xml-utils/APKBUILD
index fe8e42f7e15..322ae3775c2 100644
--- a/community/html-xml-utils/APKBUILD
+++ b/community/html-xml-utils/APKBUILD
@@ -1,47 +1,44 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=html-xml-utils
-pkgver=8.0
+pkgver=8.6
pkgrel=0
pkgdesc="A number of simple utilities for manipulating HTML and XML files."
url="https://www.w3.org/Tools/HTML-XML-utils/"
arch="all"
-license="Custom"
+license="W3C"
+checkdepends="netcat-openbsd"
subpackages="$pkgname-doc"
-source="$url/$pkgname-$pkgver.tar.gz
- getopt-musl-fix.patch
- last-test.patch"
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://www.w3.org/Tools/HTML-XML-utils//$pkgname-$pkgver.tar.gz"
prepare() {
default_prepare
+ update_config_sub
+
+ # install licence to licenses instead; disable auto install
sed -e "/doc_DATA = COPYING/d" \
-i Makefile.in
}
build() {
- cd "$builddir"
./configure \
+ --host=$CHOST \
+ --build=$CBUILD \
--prefix=/usr \
--disable-dependency-tracking
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make install DESTDIR="$pkgdir"
install -D -m 644 COPYING \
"$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
sha512sums="
-9cd6f2ec1b80c83135ea776486ba81a9f1e077c62ff39f8f7f5cc11cf89e4f91d9ad00ba33dedc1c1251118799efe8fa5425875149880628d8c65419d6c90533 html-xml-utils-8.0.tar.gz
-7b6d03798e634a72402916cdfaf69668bf19d0dc6d629860c798a6468f8077906e3ada6d1ff390cebba505ccd118cfa7f7b2e23301ac72573bde4b4eb14c94ce getopt-musl-fix.patch
-fdfaa8ff145beaf98203f834ef51763d14f5eeb1ba366578a645bfc3a0d811c2615354bea987554d6a8b131504298512238af550646e2826e00329aceee365ed last-test.patch
+0050b789a4921fa66b863255f1fd1ef9826e4b778ebc6dc67592fe854ec314b13cd8b162af67dae204018867966cfd5cb9822345917d3de3dc76c797bc0d2ec1 html-xml-utils-8.6.tar.gz
"