aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/httpie/APKBUILD')
-rw-r--r--community/httpie/APKBUILD51
1 files changed, 38 insertions, 13 deletions
diff --git a/community/httpie/APKBUILD b/community/httpie/APKBUILD
index 761e41a2b83..4660a30bb46 100644
--- a/community/httpie/APKBUILD
+++ b/community/httpie/APKBUILD
@@ -1,40 +1,65 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
# Contributor: Daniel Isaksen <d@duniel.no>
# Contributor: Mickaƫl Schoentgen <mickael@apible.io>
+# Contributor: fossdd <fossdd@pwned.life>
+# Maintainer: fossdd <fossdd@pwned.life>
pkgname=httpie
-pkgver=2.5.0
-pkgrel=1
+pkgver=3.2.2
+pkgrel=2
pkgdesc="CLI, cURL-like tool"
url="https://httpie.org/"
arch="noarch"
license="BSD-3-Clause"
depends="
- python3
- py3-setuptools
- py3-requests
+ py3-defusedxml
+ py3-multidict
+ py3-pip
py3-pygments
- py3-requests-toolbelt
py3-pysocks
- py3-defusedxml
+ py3-requests
+ py3-requests-toolbelt
+ py3-rich
+ py3-setuptools
+ py3-wheel
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="
+ py3-pytest
+ py3-pytest-httpbin
+ py3-pytest-mock
+ py3-responses
+ py3-virtualenv
+ py3-werkzeug
"
-checkdepends="py3-pytest py3-pytest-httpbin py3-responses"
source="https://files.pythonhosted.org/packages/source/h/httpie/httpie-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-pyc"
+options="!check" # fail on random network errors
# secfixes:
# 1.0.3-r0:
# - CVE-2019-10751
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest ./httpie ./tests
+ python3 -m venv --system-site-packages --without-pip --clear testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest ./httpie ./tests -k "not TestQuietFlag and not test_fetch and not check_updates"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="3bfe572b03bfde87d5a02f9ba238f9493b32e587c33fd30600a4dd6a45082eedcb2b507c7f1e3e75a423cbdcc1ff0556138897dffb7888d191834994eae9a2aa httpie-2.5.0.tar.gz"
+sha512sums="
+9c6fac71fbb3b5d7fe31736ecf7c2894638d9a720e4b8a5ff8802905fe300d4acfce9330503ca2f4465297370a5ab43a840b6df48569aae77c677fd9282c5c6a httpie-3.2.2.tar.gz
+"