aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpie/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/httpie/APKBUILD')
-rw-r--r--community/httpie/APKBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/community/httpie/APKBUILD b/community/httpie/APKBUILD
index 1a4e644360a..4660a30bb46 100644
--- a/community/httpie/APKBUILD
+++ b/community/httpie/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
# Contributor: Daniel Isaksen <d@duniel.no>
# Contributor: Mickaƫl Schoentgen <mickael@apible.io>
+# Contributor: fossdd <fossdd@pwned.life>
+# Maintainer: fossdd <fossdd@pwned.life>
pkgname=httpie
-pkgver=3.2.1
-pkgrel=1
+pkgver=3.2.2
+pkgrel=2
pkgdesc="CLI, cURL-like tool"
url="https://httpie.org/"
arch="noarch"
@@ -22,40 +23,43 @@ depends="
py3-wheel
python3
"
+makedepends="
+ py3-gpep517
+ py3-wheel
+ "
checkdepends="
py3-pytest
py3-pytest-httpbin
- py3-pytest-lazy-fixture
+ py3-pytest-mock
py3-responses
py3-virtualenv
+ py3-werkzeug
"
source="https://files.pythonhosted.org/packages/source/h/httpie/httpie-$pkgver.tar.gz"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-pyc"
+options="!check" # fail on random network errors
# secfixes:
# 1.0.3-r0:
# - CVE-2019-10751
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- virtualenv --system-site-packages .venv
- # activate script gets created after running virtualenv
- # shellcheck disable=SC1091
- . .venv/bin/activate
- pip install .
-
- python3 -m pytest ./httpie ./tests -k "not TestQuietFlag and not test_fetch and not check_updates"
-
- deactivate
+ python3 -m venv --system-site-packages --without-pip --clear testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest ./httpie ./tests -k "not TestQuietFlag and not test_fetch and not check_updates"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-eb61d60dd3a8e5bff3f84a51ec02521f06a0dc918a42e24d055294daf1a26abba55406d40d154380e91605d47754207b8678b52e63b855d5480de10b35944dda httpie-3.2.1.tar.gz
+9c6fac71fbb3b5d7fe31736ecf7c2894638d9a720e4b8a5ff8802905fe300d4acfce9330503ca2f4465297370a5ab43a840b6df48569aae77c677fd9282c5c6a httpie-3.2.2.tar.gz
"