aboutsummaryrefslogtreecommitdiffstats
path: root/community/httpry/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/httpry/APKBUILD')
-rw-r--r--community/httpry/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/httpry/APKBUILD b/community/httpry/APKBUILD
index 555f91b9db5..a0bfb519150 100644
--- a/community/httpry/APKBUILD
+++ b/community/httpry/APKBUILD
@@ -2,28 +2,28 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=httpry
pkgver=0.1.8
-pkgrel=1
+pkgrel=2
pkgdesc="A packet sniffer designed for HTTP traffic"
# Sources at https://github.com/jbittel/httpry/
-url="http://dumpsterventures.com/jason/httpry/"
+url="https://dumpsterventures.com/jason/httpry/"
arch="all"
license="GPL-2.0"
makedepends="libpcap-dev"
subpackages="$pkgname-doc"
-source="https://github.com/jbittel/httpry/archive/httpry-0.1.8.tar.gz"
+source="https://github.com/jbittel/httpry/archive/httpry-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
- cd "$builddir"
- make || return 1
+ make
}
package() {
- cd "$builddir"
install -m755 -D "$builddir"/$pkgname \
- "$pkgdir"/usr/sbin/$pkgname || return 1
+ "$pkgdir"/usr/sbin/$pkgname
install -m644 -D "$builddir"/$pkgname.1 \
- "$pkgdir"/usr/share/man/man1/$pkgname.1 || return 1
+ "$pkgdir"/usr/share/man/man1/$pkgname.1
}
-sha512sums="d242d5bd60296f1a5836c3c9449c732a77eeda69c103718e75debfeb97d528b87bf895312883f194f0a35c37c1d59e95086b1f7dd8f3ae8627428657d49cebed httpry-0.1.8.tar.gz"
+sha512sums="
+d242d5bd60296f1a5836c3c9449c732a77eeda69c103718e75debfeb97d528b87bf895312883f194f0a35c37c1d59e95086b1f7dd8f3ae8627428657d49cebed httpry-0.1.8.tar.gz
+"