aboutsummaryrefslogtreecommitdiffstats
path: root/community/hugo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hugo/APKBUILD')
-rw-r--r--community/hugo/APKBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
index 62247816f98..25e25d152e2 100644
--- a/community/hugo/APKBUILD
+++ b/community/hugo/APKBUILD
@@ -2,31 +2,35 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=hugo
-pkgver=0.88.1
+pkgver=0.122.0
pkgrel=1
pkgdesc="Fast and flexible static site generator written in Go"
url="https://gohugo.io/"
-arch="all"
license="Apache-2.0"
+arch="all !ppc64le" # fails tests
makedepends="go"
-subpackages="$pkgname-doc $pkgname-bash-completion"
+checkdepends="npm py3-docutils tzdata"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="https://github.com/gohugoio/hugo/archive/v$pkgver/hugo-$pkgver.tar.gz
- skip-git-tests.patch
skip-para-test.patch
- skip-js-tests.patch
- increase-timeout-pagebundler-test.patch
skip-image-test.patch
"
-# npm is not available on mips64
-if [ "$CARCH" != "mips64" ]; then
- checkdepends="npm"
-fi
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v -o bin/$pkgname --tags extended
./bin/hugo gen man
- ./bin/hugo gen autocomplete --completionfile="$builddir"/hugo.bash
+ ./bin/hugo completion bash > hugo.bash
+ ./bin/hugo completion fish > hugo.fish
+ ./bin/hugo completion zsh > hugo.zsh
}
check() {
@@ -36,15 +40,17 @@ check() {
package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 man/*.1 -t "$pkgdir"/usr/share/man/man1
+
install -Dm644 hugo.bash \
"$pkgdir"/usr/share/bash-completion/completions/hugo
+ install -Dm644 hugo.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/hugo.fish
+ install -Dm644 hugo.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_hugo
}
sha512sums="
-2d0a9640f4209259ab7c7d8198306a7131bb9bfc1071a20ad883b83cf89f14c1da9785afd4fb67250e6177dc32042965cb3cba9d733bbe8e9fc147da69fc8537 hugo-0.88.1.tar.gz
-f07d458b5df72d0b10e0fd9ec6120502b62af1ee347f0ec83eda99147c525327c0098150db80450da48c5bc03d825279e35f0940dae5d909203757abb6bd1a20 skip-git-tests.patch
+f2eac9b9b227b78647c8d9c5c48d409c8d056aaaf8e2523458f9c256fd49bd5b4f3392a80789133bf8603369ff3522783a7605a42f65f33070b26356070a51d1 hugo-0.122.0.tar.gz
6ba192d8cb67f115f7ce596c297a55fc64713a4cdb0077cfbb7e45051c7560f5b668da88f513d4f34d8e0eeb4a9d991c5312d62e454c85e95960d8a33f0f8f69 skip-para-test.patch
-0eada6d4f318775d24a55bec65349e62148b71322f084874a608596f8248cc948632e5f1823c3e86463090e35777e14784c2bcdb6493ad71be9b98ecc4700f24 skip-js-tests.patch
-0eafc165979d869ef401fec050678ba025431ac66b79a9761879024da8326e2dd5e9d14d90e32c3071d83dbac6973c2b4f954217e789944524b660a09131b298 increase-timeout-pagebundler-test.patch
0feb0495f03315c9224b301ea955061fcbbf9ae8f871640fbb4b5c0792785a714f3a030f702a1f1f6a8048d60f07a133df4ced2a989df0b9c851b8503b59d26d skip-image-test.patch
"