aboutsummaryrefslogtreecommitdiffstats
path: root/community/hugo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hugo/APKBUILD')
-rw-r--r--community/hugo/APKBUILD49
1 files changed, 31 insertions, 18 deletions
diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
index 1074f2bb335..e1744427806 100644
--- a/community/hugo/APKBUILD
+++ b/community/hugo/APKBUILD
@@ -1,41 +1,54 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=hugo
-pkgver=0.79.1
+pkgver=0.124.1
pkgrel=0
pkgdesc="Fast and flexible static site generator written in Go"
url="https://gohugo.io/"
-arch="all !x86 !s390x" # tests fail on x86 and s390x
license="Apache-2.0"
+arch="all !ppc64le !riscv64" # fails tests
makedepends="go"
-subpackages="$pkgname-doc $pkgname-bash-completion"
-source="
- $pkgname-$pkgver.tar.gz::https://github.com/gohugoio/hugo/archive/v$pkgver.tar.gz
- 0001-Remove-git-tests.patch
- 0002-skip-tests-that-need-nodejs.patch
+checkdepends="npm py3-docutils tzdata"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
"
+source="https://github.com/gohugoio/hugo/archive/v$pkgver/hugo-$pkgver.tar.gz
+ skip-para-test.patch
+ "
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v -o bin/$pkgname --tags extended
./bin/hugo gen man
- ./bin/hugo gen autocomplete --completionfile="$builddir"/hugo.bash
+ ./bin/hugo completion bash > hugo.bash
+ ./bin/hugo completion fish > hugo.fish
+ ./bin/hugo completion zsh > hugo.zsh
}
check() {
- # image_test.so:548 fails
- case "$CARCH" in
- aarch64|ppc64le) return 0 ;;
- esac
go test ./...
}
package() {
- install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
- install -Dm644 "$builddir"/man/*.1 -t "$pkgdir"/usr/share/man/man1
- install -Dm644 "$builddir"/hugo.bash \
+ install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 man/*.1 -t "$pkgdir"/usr/share/man/man1
+
+ install -Dm644 hugo.bash \
"$pkgdir"/usr/share/bash-completion/completions/hugo
+ install -Dm644 hugo.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/hugo.fish
+ install -Dm644 hugo.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_hugo
}
-sha512sums="61db9bef0a99d2885c41583aa785da90870583e2c5994b7f5857fc7a8a574d16f3e112aa4f6739186c4e11a48a779f1175f8cdccba8035cc352617ec6db326f9 hugo-0.79.1.tar.gz
-57be9a6c8e49bd2a75921d51d8dc503439f68453a6c9803c9cecef8bb63541f10d8b652db151426949c1bcf134a96eec0253ee4a61c0987143d6159ea49e9588 0001-Remove-git-tests.patch
-b4656113d6918912d85434bb72e0183b25ffab9e298b63c35b10b6cbcaa89d9ab4a878c4c28bc3feb7bc9b6c7706333e460b6470c92a07e90a91975e1326fd58 0002-skip-tests-that-need-nodejs.patch"
+sha512sums="
+29f51a08f9e757a716c2f7845efc08b1ca3b0bf8e70fd06491735a123ca7da8e169116fa003c147be08d2d5f9752473e9a569085728ec0a9ed7850bd57ba8f93 hugo-0.124.1.tar.gz
+6ba192d8cb67f115f7ce596c297a55fc64713a4cdb0077cfbb7e45051c7560f5b668da88f513d4f34d8e0eeb4a9d991c5312d62e454c85e95960d8a33f0f8f69 skip-para-test.patch
+"