aboutsummaryrefslogtreecommitdiffstats
path: root/community/hugo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hugo/APKBUILD')
-rw-r--r--community/hugo/APKBUILD42
1 files changed, 23 insertions, 19 deletions
diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
index 8e7f5a5705c..01755468300 100644
--- a/community/hugo/APKBUILD
+++ b/community/hugo/APKBUILD
@@ -2,33 +2,35 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=hugo
-pkgver=0.92.1
+pkgver=0.125.1
pkgrel=0
pkgdesc="Fast and flexible static site generator written in Go"
url="https://gohugo.io/"
license="Apache-2.0"
-arch="all"
+arch="all !ppc64le !riscv64" # fails tests
makedepends="go"
-checkdepends="py3-docutils"
-subpackages="$pkgname-doc $pkgname-bash-completion"
+checkdepends="npm py3-docutils tzdata"
+subpackages="
+ $pkgname-doc
+ $pkgname-bash-completion
+ $pkgname-fish-completion
+ $pkgname-zsh-completion
+ "
source="https://github.com/gohugoio/hugo/archive/v$pkgver/hugo-$pkgver.tar.gz
- skip-git-tests.patch
+ Fix-TestColorLuminance-on-s390x.patch
skip-para-test.patch
- skip-js-tests.patch
- increase-timeout-pagebundler-test.patch
- skip-image-test.patch
"
-
-# npm is not available on riscv64
-if [ "$CARCH" != "riscv64" ]; then
- checkdepends="$checkdepends npm"
-fi
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build -v -o bin/$pkgname --tags extended
./bin/hugo gen man
- ./bin/hugo gen autocomplete --completionfile="$builddir"/hugo.bash
+ ./bin/hugo completion bash > hugo.bash
+ ./bin/hugo completion fish > hugo.fish
+ ./bin/hugo completion zsh > hugo.zsh
}
check() {
@@ -38,15 +40,17 @@ check() {
package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
install -Dm644 man/*.1 -t "$pkgdir"/usr/share/man/man1
+
install -Dm644 hugo.bash \
"$pkgdir"/usr/share/bash-completion/completions/hugo
+ install -Dm644 hugo.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/hugo.fish
+ install -Dm644 hugo.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_hugo
}
sha512sums="
-d5041e89293ec75f2f4622fe3b622ed7a2c920512c39a6fac4364f6e8c033130a09043403dae186b71a78a42118820ae88309e404dd788f77a9bf77fe526759f hugo-0.92.1.tar.gz
-f07d458b5df72d0b10e0fd9ec6120502b62af1ee347f0ec83eda99147c525327c0098150db80450da48c5bc03d825279e35f0940dae5d909203757abb6bd1a20 skip-git-tests.patch
+9aaa4d1bfb1fcd9238a3774b749494af035974fdee52f8959ece08cd4e7ae1e37c351af593ab0b6d2a7407823656373e15a08e8e0f196c32ec69fe8d32e7978d hugo-0.125.1.tar.gz
+dbb6ae8e691c634d8c3ab42c4bd8cf0e57ea114f9a6d6e1d2d479f78df38c9f1c01f98878f9e72710d64108141d0146a7cf6eb915a34bad2f8040cda9cba9e46 Fix-TestColorLuminance-on-s390x.patch
6ba192d8cb67f115f7ce596c297a55fc64713a4cdb0077cfbb7e45051c7560f5b668da88f513d4f34d8e0eeb4a9d991c5312d62e454c85e95960d8a33f0f8f69 skip-para-test.patch
-143a337c5f7a77636774782bb3f87e6ae0db8741186bab5d6466f0e1700f7303a6a22c092852489995b1f024736627245c52a295c3f37b37135c0d05737c06be skip-js-tests.patch
-0eafc165979d869ef401fec050678ba025431ac66b79a9761879024da8326e2dd5e9d14d90e32c3071d83dbac6973c2b4f954217e789944524b660a09131b298 increase-timeout-pagebundler-test.patch
-0feb0495f03315c9224b301ea955061fcbbf9ae8f871640fbb4b5c0792785a714f3a030f702a1f1f6a8048d60f07a133df4ced2a989df0b9c851b8503b59d26d skip-image-test.patch
"