aboutsummaryrefslogtreecommitdiffstats
path: root/community/hwinfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hwinfo/APKBUILD')
-rw-r--r--community/hwinfo/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/hwinfo/APKBUILD b/community/hwinfo/APKBUILD
index ea575442674..ad65f44e756 100644
--- a/community/hwinfo/APKBUILD
+++ b/community/hwinfo/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=hwinfo
-pkgver=21.74
+pkgver=23.2
pkgrel=0
pkgdesc="Hardware information tool"
url="https://github.com/openSUSE/hwinfo"
@@ -19,12 +19,13 @@ export HWINFO_VERSION=$pkgver
build() {
# Build full and tiny static libraries.
#make tinystatic # FIXME: fails
- make static
+ # this takes forever but it's not stuck
+ make -j1 static
cp src/libhd*.a .
make clean
# Build full shared library.
- make shared LIBDIR=/usr/lib
+ make -j1 shared LIBDIR=/usr/lib
}
package() {
@@ -44,6 +45,8 @@ package() {
cp doc/*.8 "$pkgdir"/usr/share/man/man8/
}
-sha512sums="0f976e3bf9313b01ee58dd040b75dc5c01b17bfff7006126c6fc127e729f35ae2d9e8a34d7083f51f6e80dfcca78efbb7a3c8bfabb2c72f662c96193903a9a74 hwinfo-21.74.tar.gz
-581db9d2324c8ba686a1676c9f673885bc927c160d420739b421596c5a8106e80cb26698e2fca8c77147b62667ec4c2a933e6373ad980658048ed1718d906707 respect-flags.patch
-3bf22dc8afecbdf080b882358e866dc01bc8837522cf0f47409c514892a0fe0900d060f87d28dd3cb5e0ee4224cbec415273024efd70fcdb947ca004915d2543 eudev-udevadm-path.patch"
+sha512sums="
+86096455cc58ecdd3be4306d61beaea02da39b8ee3b2a99966d4aaf022e276616329ca82550d7903e2aed9b1723a99b2305617fb85df21c1d2024ce46b447af3 hwinfo-23.2.tar.gz
+2016f76bdfd65fb9b8f331ed82d6e5a1a85ab003615fe6815c3b41127398ae25fedd83abada9930dcbc9409fda69cf701ebdc5f12874e518784e194fcf4a0ff8 respect-flags.patch
+3bf22dc8afecbdf080b882358e866dc01bc8837522cf0f47409c514892a0fe0900d060f87d28dd3cb5e0ee4224cbec415273024efd70fcdb947ca004915d2543 eudev-udevadm-path.patch
+"