aboutsummaryrefslogtreecommitdiffstats
path: root/community/hwinfo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hwinfo/APKBUILD')
-rw-r--r--community/hwinfo/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/hwinfo/APKBUILD b/community/hwinfo/APKBUILD
index 6688087b71a..ad65f44e756 100644
--- a/community/hwinfo/APKBUILD
+++ b/community/hwinfo/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=hwinfo
-pkgver=21.76
-pkgrel=1
+pkgver=23.2
+pkgrel=0
pkgdesc="Hardware information tool"
url="https://github.com/openSUSE/hwinfo"
arch="all"
@@ -19,12 +19,13 @@ export HWINFO_VERSION=$pkgver
build() {
# Build full and tiny static libraries.
#make tinystatic # FIXME: fails
- make static
+ # this takes forever but it's not stuck
+ make -j1 static
cp src/libhd*.a .
make clean
# Build full shared library.
- make shared LIBDIR=/usr/lib
+ make -j1 shared LIBDIR=/usr/lib
}
package() {
@@ -45,7 +46,7 @@ package() {
}
sha512sums="
-23a2c50c0a787c669ea6d2c8533c85e142c4e3248c6dbd3c46e6c8e99fa310ba25541f83b41eeb58bb491417a688561932f3b70a045d8b53e941d2a066630fd3 hwinfo-21.76.tar.gz
-581db9d2324c8ba686a1676c9f673885bc927c160d420739b421596c5a8106e80cb26698e2fca8c77147b62667ec4c2a933e6373ad980658048ed1718d906707 respect-flags.patch
+86096455cc58ecdd3be4306d61beaea02da39b8ee3b2a99966d4aaf022e276616329ca82550d7903e2aed9b1723a99b2305617fb85df21c1d2024ce46b447af3 hwinfo-23.2.tar.gz
+2016f76bdfd65fb9b8f331ed82d6e5a1a85ab003615fe6815c3b41127398ae25fedd83abada9930dcbc9409fda69cf701ebdc5f12874e518784e194fcf4a0ff8 respect-flags.patch
3bf22dc8afecbdf080b882358e866dc01bc8837522cf0f47409c514892a0fe0900d060f87d28dd3cb5e0ee4224cbec415273024efd70fcdb947ca004915d2543 eudev-udevadm-path.patch
"