aboutsummaryrefslogtreecommitdiffstats
path: root/community/hwloc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hwloc/APKBUILD')
-rw-r--r--community/hwloc/APKBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/community/hwloc/APKBUILD b/community/hwloc/APKBUILD
deleted file mode 100644
index 1f46cba3d35..00000000000
--- a/community/hwloc/APKBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
-pkgname=hwloc
-pkgver=2.7.0
-pkgrel=2
-pkgdesc="Portable abstraction of hierarchical hardware architectures"
-url="https://www.open-mpi.org/"
-arch="all"
-license="BSD-3-Clause"
-makedepends="cairo-dev eudev-dev libxml2-dev ncurses-dev"
-case "$CARCH" in
- arm*) true;;
- *) makedepends="$makedepends numactl-dev";;
-esac
-options="!check" # fails on multiple arches with different tests
-subpackages="
- $pkgname-dev
- $pkgname-doc
- $pkgname-bash-completion
- $pkgname-tools:_tools"
-source="https://www.open-mpi.org/software/hwloc/v${pkgver%.*}/downloads/hwloc-$pkgver.tar.bz2"
-
-build() {
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --mandir=/usr/share/man \
- --localstatedir=/var
- make
-}
-
-check() {
- make -C "$builddir" check
-}
-
-package() {
- make -C "$builddir" DESTDIR="$pkgdir" install
-}
-
-_tools() {
- pkgdesc="Portable hardware locality tools"
-
- mkdir -p "$subpkgdir"/usr
- mv "$pkgdir"/usr/bin "$subpkgdir"/usr
- mkdir -p "$subpkgdir"/usr/share/applications
- mv "$pkgdir"/usr/share/applications/lstopo.desktop "$subpkgdir"/usr/share/applications
-}
-
-sha512sums="
-9f3a9d66ad9762ca88f9e38950a7c1beb208337517b635c4c363dcfbb050706562511cb12115bd403c0a86c0f7270174dd1888e7803d88557e41ae018e7e7e2f hwloc-2.7.0.tar.bz2
-"