aboutsummaryrefslogtreecommitdiffstats
path: root/community/hydroxide/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hydroxide/APKBUILD')
-rw-r--r--community/hydroxide/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/community/hydroxide/APKBUILD b/community/hydroxide/APKBUILD
index cf6247c84bd..ec745bd3cd8 100644
--- a/community/hydroxide/APKBUILD
+++ b/community/hydroxide/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Dekedro <dekedro@tankers.xyz>
+# Maintainer: Dekedro <dekedro@protonmail.com>
pkgname=hydroxide
-pkgver=0.2.23
-pkgrel=0
+pkgver=0.2.28
+pkgrel=5
pkgdesc="Third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
url="https://github.com/emersion/hydroxide"
license="MIT"
@@ -10,14 +10,18 @@ makedepends="go"
options="net !check" # no tests
source="https://github.com/emersion/hydroxide/releases/download/v$pkgver/hydroxide-$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build ./cmd/hydroxide
}
package() {
- install -Dm755 "$builddir"/hydroxide "$pkgdir"/usr/bin/hydroxide
+ install -Dm755 hydroxide -t "$pkgdir"/usr/bin/
}
sha512sums="
-9f2c9b59cb7c1dfcfec9cc626767f340b1d5caea4db69e81de6b87c4bcf26840d14cd6568a0d3aad36d8e31184e2f1827a5e27745338bc2f38265ce64fe2d4a4 hydroxide-0.2.23.tar.gz
+55472d5f081eb2827cd37ebb02e66c5831cfde7f375c1800142cb888837bb05ae07da873ddca33b4b83a0ed2adb4587d90d43e05c1478e2696de9b7871e213f0 hydroxide-0.2.28.tar.gz
"