aboutsummaryrefslogtreecommitdiffstats
path: root/community/hydroxide/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hydroxide/APKBUILD')
-rw-r--r--community/hydroxide/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/community/hydroxide/APKBUILD b/community/hydroxide/APKBUILD
index 04723196c23..8ae0841b8ec 100644
--- a/community/hydroxide/APKBUILD
+++ b/community/hydroxide/APKBUILD
@@ -1,23 +1,27 @@
-# Maintainer: Dekedro <dekedro@tankers.xyz>
+# Maintainer: Dekedro <dekedro@protonmail.com>
pkgname=hydroxide
-pkgver=0.2.21
-pkgrel=1
+pkgver=0.2.28
+pkgrel=4
pkgdesc="Third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
url="https://github.com/emersion/hydroxide"
license="MIT"
-arch="all !mips !mips64 !riscv64" # failure to build github.com/boltdb/bolt
+arch="all !riscv64" # failure to build github.com/boltdb/bolt
makedepends="go"
options="net !check" # no tests
source="https://github.com/emersion/hydroxide/releases/download/v$pkgver/hydroxide-$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build ./cmd/hydroxide
}
package() {
- install -Dm755 "$builddir"/hydroxide "$pkgdir"/usr/bin/hydroxide
+ install -Dm755 hydroxide -t "$pkgdir"/usr/bin/
}
sha512sums="
-bc6ec19e927bd8ddc87099d36af41ba7e87d143ec24ee0e2c840c23a15c94100fcf52b826b4b86aa4873fdd93270336d59f6621625a6244abdc1649811d4d6c1 hydroxide-0.2.21.tar.gz
+55472d5f081eb2827cd37ebb02e66c5831cfde7f375c1800142cb888837bb05ae07da873ddca33b4b83a0ed2adb4587d90d43e05c1478e2696de9b7871e213f0 hydroxide-0.2.28.tar.gz
"