aboutsummaryrefslogtreecommitdiffstats
path: root/community/hyperfine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hyperfine/APKBUILD')
-rw-r--r--community/hyperfine/APKBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/community/hyperfine/APKBUILD b/community/hyperfine/APKBUILD
index 1d04e052b95..2fa3030a6d3 100644
--- a/community/hyperfine/APKBUILD
+++ b/community/hyperfine/APKBUILD
@@ -1,30 +1,32 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=hyperfine
-pkgver=1.13.0
+pkgver=1.18.0
pkgrel=0
pkgdesc="Command-line benchmarking tool"
url="https://github.com/sharkdp/hyperfine"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # Limited by cargo
+# s390x: nix statfs broken with musl
+arch="all !s390x"
license="Apache-2.0 AND MIT"
-makedepends="cargo"
-subpackages="$pkgname-doc
+makedepends="cargo cargo-auditable"
+subpackages="
+ $pkgname-doc
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/hyperfine/archive/v$pkgver.tar.gz
- minimize-size.patch
- "
+source="https://github.com/sharkdp/hyperfine/archive/v$pkgver/hyperfine-$pkgver.tar.gz"
+
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
prepare() {
default_prepare
- cargo fetch --locked
+ cargo fetch --target="$CTARGET" --locked
}
build() {
- cargo build --frozen --release
+ cargo auditable build --frozen --release
}
check() {
@@ -42,10 +44,9 @@ package() {
install -Dm644 target/release/build/hyperfine-*/out/_hyperfine \
"$pkgdir/usr/share/zsh/site-functions/_hyperfine"
install -Dm644 target/release/build/hyperfine-*/out/hyperfine.fish \
- "$pkgdir/usr/share/fish/completions/hyperfine.fish"
+ "$pkgdir/usr/share/fish/vendor_completions.d/hyperfine.fish"
}
sha512sums="
-c1bd9733f50121cb0a3452c3f650763875dce0edf38d091d680072e2738994be4f32c6ffe8bf145f0d8fb3d57703787a31493f67ca761eecb30e3848c8a435e4 hyperfine-1.13.0.tar.gz
-f6b18843508903d9c1ac5d7213d817723741428d36d8d7c9965f4f6c6d01a3de2eefb501a7bd2c196507dea33c4093d7046c24e0ead086008fc15a0e0e7d71c5 minimize-size.patch
+9792679b55efa224f31aa789780db36aa2f036114eec704703d46418c777fa512f28a3910928d894f3abb02c24dbd84d13791824eaa4c53a876c69e5d6f1ede4 hyperfine-1.18.0.tar.gz
"