aboutsummaryrefslogtreecommitdiffstats
path: root/community/hyperfine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/hyperfine/APKBUILD')
-rw-r--r--community/hyperfine/APKBUILD35
1 files changed, 22 insertions, 13 deletions
diff --git a/community/hyperfine/APKBUILD b/community/hyperfine/APKBUILD
index 0aaaa062058..2fa3030a6d3 100644
--- a/community/hyperfine/APKBUILD
+++ b/community/hyperfine/APKBUILD
@@ -1,28 +1,36 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=hyperfine
-pkgver=1.11.0
-pkgrel=1
+pkgver=1.18.0
+pkgrel=0
pkgdesc="Command-line benchmarking tool"
url="https://github.com/sharkdp/hyperfine"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le" # Limited by cargo
+# s390x: nix statfs broken with musl
+arch="all !s390x"
license="Apache-2.0 AND MIT"
-makedepends="cargo"
-subpackages="$pkgname-doc
+makedepends="cargo cargo-auditable"
+subpackages="
+ $pkgname-doc
$pkgname-bash-completion
$pkgname-zsh-completion
$pkgname-fish-completion
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sharkdp/hyperfine/archive/v$pkgver.tar.gz
- minimize-size.patch
- "
+source="https://github.com/sharkdp/hyperfine/archive/v$pkgver/hyperfine-$pkgver.tar.gz"
+
+export CARGO_PROFILE_RELEASE_OPT_LEVEL="z"
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
build() {
- cargo build --release --locked
+ cargo auditable build --frozen --release
}
check() {
- cargo test all --release --locked
+ cargo test all --frozen
}
package() {
@@ -36,8 +44,9 @@ package() {
install -Dm644 target/release/build/hyperfine-*/out/_hyperfine \
"$pkgdir/usr/share/zsh/site-functions/_hyperfine"
install -Dm644 target/release/build/hyperfine-*/out/hyperfine.fish \
- "$pkgdir/usr/share/fish/completions/hyperfine.fish"
+ "$pkgdir/usr/share/fish/vendor_completions.d/hyperfine.fish"
}
-sha512sums="2b2569c997e3ab14e7edae883d3d6f805ed571a90585e1ae17cb1dffbcb77ae7ff5428a7defad3694d98f061f4571d938ade8bcb7efa757a245df0ffa685af56 hyperfine-1.11.0.tar.gz
-f6b18843508903d9c1ac5d7213d817723741428d36d8d7c9965f4f6c6d01a3de2eefb501a7bd2c196507dea33c4093d7046c24e0ead086008fc15a0e0e7d71c5 minimize-size.patch"
+sha512sums="
+9792679b55efa224f31aa789780db36aa2f036114eec704703d46418c777fa512f28a3910928d894f3abb02c24dbd84d13791824eaa4c53a876c69e5d6f1ede4 hyperfine-1.18.0.tar.gz
+"