aboutsummaryrefslogtreecommitdiffstats
path: root/community/i2c-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/i2c-tools/APKBUILD')
-rw-r--r--community/i2c-tools/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/i2c-tools/APKBUILD b/community/i2c-tools/APKBUILD
index 40cfa7df853..c382daf985d 100644
--- a/community/i2c-tools/APKBUILD
+++ b/community/i2c-tools/APKBUILD
@@ -2,17 +2,16 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=i2c-tools
pkgver=4.3
-pkgrel=0
+pkgrel=3
pkgdesc="Tools for monitoring I2C devices"
url="https://i2c.wiki.kernel.org/index.php/I2C_Tools"
arch="all"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
options="!check" #no test/check provided by upstream
-makedepends="linux-headers python3-dev"
+makedepends="linux-headers python3-dev py3-setuptools"
subpackages="$pkgname-dev $pkgname-doc py3-smbus:py"
source="https://fossies.org/linux/misc/i2c-tools-$pkgver.tar.gz"
-
prepare() {
default_prepare
sed -e "s|^DESTDIR.*|DESTDIR = \"$pkgdir\"|" \
@@ -40,7 +39,7 @@ package() {
make install
cd "$builddir"/py-smbus
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="