aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3blocks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/i3blocks/APKBUILD')
-rw-r--r--community/i3blocks/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/i3blocks/APKBUILD b/community/i3blocks/APKBUILD
new file mode 100644
index 00000000000..e4ca9dc6d85
--- /dev/null
+++ b/community/i3blocks/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Marvin Preuss <marvin@xsteadfastx.org>
+# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
+pkgname=i3blocks
+pkgver=1.5
+pkgrel=0
+pkgdesc="A minimalist scheduler for your status line scripts"
+url="https://github.com/vivien/i3blocks"
+arch="all"
+license="GPL-3.0-or-later"
+options="!check" # no test suite
+makedepends="ronn autoconf automake bash-completion-dev"
+subpackages="$pkgname-bash-completion $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vivien/i3blocks/archive/$pkgver.tar.gz
+ bash-completion.patch
+ "
+
+prepare() {
+ default_prepare
+ autoreconf -fi
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="
+759829d59f94070251378d437891c2df05715fbd0b734c34dd41767d61957f301c6125b0058668295b8eeac29038fae6b2e8c194f903398ee736662213d1d534 i3blocks-1.5.tar.gz
+5d5034c492302e73c7c9c41fc4de1828472ef5e019fc2535e738dca5a27b90d7454863accb687fcc3def8cd9964ab51bc1d63f1472d5f7377d822c967af2b511 bash-completion.patch
+"