aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3lock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/i3lock/APKBUILD')
-rw-r--r--community/i3lock/APKBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/community/i3lock/APKBUILD b/community/i3lock/APKBUILD
index af0f3fcbc9d..b63956d55a7 100644
--- a/community/i3lock/APKBUILD
+++ b/community/i3lock/APKBUILD
@@ -1,17 +1,26 @@
# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
-# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=i3lock
-pkgver=2.13
+pkgver=2.15
pkgrel=0
pkgdesc="An improved screenlocker based upon XCB and PAM"
url="https://i3wm.org/i3lock/"
arch="all"
license="MIT"
depends="xkeyboard-config"
-makedepends="libev-dev cairo-dev linux-pam-dev libxkbcommon-dev
- xcb-util-image-dev xcb-util-xrm-dev"
+makedepends="
+ cairo-dev
+ libev-dev
+ libxkbcommon-dev
+ linux-pam-dev
+ meson
+ xcb-util-image-dev
+ xcb-util-xrm-dev
+ "
subpackages="$pkgname-doc"
-source="https://i3wm.org/i3lock/i3lock-$pkgver.tar.bz2"
+source="https://i3wm.org/i3lock/i3lock-$pkgver.tar.xz"
+# fails if running under a wayland session even for version output
+options="!check"
prepare() {
default_prepare
@@ -21,23 +30,18 @@ prepare() {
}
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --disable-builddir
- make
+ abuild-meson . output
+ meson compile -C output
}
check() {
- ./i3lock -v
+ ./output/i3lock -v
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="3a9bed3d14a2d59e641b3603448bb46d769104995b1c0239eca87d582e80e64dd8905b8e455bd5b0e635d4b37d7a87208d8de37253e9af799c65f4f8d396789d i3lock-2.13.tar.bz2"
+sha512sums="
+6079f5233c0820c6e38f3cd8f3732d585e95e7d670408e4fb18ab580a2e1face8f3d6ea13eaaeedc8671f74def917183667e736b35306bf7c630d40625b41ac2 i3lock-2.15.tar.xz
+"