aboutsummaryrefslogtreecommitdiffstats
path: root/community/i3wm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/i3wm/APKBUILD')
-rw-r--r--community/i3wm/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/i3wm/APKBUILD b/community/i3wm/APKBUILD
index 76ab7ce6745..c33bb36b13a 100644
--- a/community/i3wm/APKBUILD
+++ b/community/i3wm/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=i3wm
-pkgver=4.19.2
+pkgver=4.23
pkgrel=0
pkgdesc="Improved dynamic tiling window manager"
url="https://i3wm.org"
@@ -18,7 +18,7 @@ makedepends="
libxcb-dev
libxkbcommon-dev
pango-dev
- pcre-dev
+ pcre2-dev
perl
startup-notification-dev
xcb-util-cursor-dev
@@ -38,9 +38,13 @@ source="
builddir="$srcdir/i3-$pkgver"
options="!check" # missing perl bindings for libxcb
+# 4.22 merged gaps into mainline, so provide it here for a bit
+provides="i3wm-gaps=$pkgver-r$pkgrel"
+replaces="i3wm-gaps"
+
build() {
- abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ abuild-meson -Db_lto=true . output
+ meson compile -C output
}
package() {
@@ -50,8 +54,10 @@ package() {
savetree() {
pkgdesc="Session export tool for $pkgname"
depends="$pkgname=$pkgver-r$pkgrel perl-anyevent-i3"
- mkdir -p "$subpkgdir"/usr/bin
- mv "$pkgdir"/usr/bin/i3-save-tree "$subpkgdir"/usr/bin/
+
+ amove usr/bin/i3-save-tree
}
-sha512sums="58f08228d842cd3c2bc417b72f6279fcd7050879e5fd4064b2cb00edaf98b6605d5b2361608f9534991a0f8357d3294e881c7e314f33dc075241cc45ca5ed94d i3-4.19.2.tar.xz"
+sha512sums="
+342bd6e9ff952dd2408c9af6e79e0279cb5e7388a510dd461be84a82a5fbedb92fa35065d4b76fd88e392026f2eb4979160891ae468f421935fe5922f58a66ba i3-4.23.tar.xz
+"