aboutsummaryrefslogtreecommitdiffstats
path: root/community/ibmswtpm2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ibmswtpm2/APKBUILD')
-rw-r--r--community/ibmswtpm2/APKBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/community/ibmswtpm2/APKBUILD b/community/ibmswtpm2/APKBUILD
index f9c1406848d..72d88dd1ceb 100644
--- a/community/ibmswtpm2/APKBUILD
+++ b/community/ibmswtpm2/APKBUILD
@@ -1,28 +1,29 @@
# Contributor: Olliver Schinagl <oliver@schinagl.nl>
# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
-pkgname="ibmswtpm2"
-pkgver="1661"
-pkgrel=0
+pkgname=ibmswtpm2
+pkgver=1682
+pkgrel=1
pkgdesc="Software implementation of the TCG TPM 2.0 specification by IBM"
-url="http://ibmswtpm.sourceforge.net/ibmswtpm2.html"
+url="https://ibmswtpm.sourceforge.net/ibmswtpm2.html"
arch="all"
license="MIT"
-makedepends="musl-dev openssl-dev"
+makedepends="musl-dev openssl-dev>3"
options="!check" # No selftest available
-source="https://downloads.sourceforge.net/project/ibmswtpm2/ibmtpm${pkgver}.tar.gz
- riscv64.patch"
-builddir="${srcdir}/src"
+source="https://downloads.sourceforge.net/project/ibmswtpm2/ibmtpm$pkgver.tar.gz
+ openssl-3.1.patch
+ "
+builddir="$srcdir/src"
build() {
make
}
package() {
- install -D -m 0655 -t "${pkgdir}/usr/bin" \
- "${builddir}/tpm_server"
+ install -D -m 0655 -t "$pkgdir/usr/bin" \
+ "$builddir/tpm_server"
}
sha512sums="
-942baa26311472d6af6b2c3b3b4132718e5e2b1eaa7decb0f64d910cbb7acaa4814ac95b18b5f2a4ea43990978cd5577b8fd50b158a055ff475710ad2426f6cb ibmtpm1661.tar.gz
-52f0416909c89b46fefba50523e0360fb86661eeb58069276b3cfa2c500d3bf5eb5ef5efea6528da8e2f9638d3a9b75e3c414320f239d72993dd5fa3472e8710 riscv64.patch
+564c2154e5459cbbf4ec052bea7909d1eaff0aa07b291c7de44b1204ecfda3c4156fa18da4499e4202b8772b54ae30d0c7c89bd12cd415f3882d17c8d340686d ibmtpm1682.tar.gz
+a815b71ae92e7375ef3d63e4a0b3efa4130a5c6a2371e175f2c7ac865073509e1936ce44aa22e8d2ef6a21018406599245bf99cc536771f24de10c8dc8ef73fe openssl-3.1.patch
"