aboutsummaryrefslogtreecommitdiffstats
path: root/community/ibus/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ibus/APKBUILD')
-rw-r--r--community/ibus/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/ibus/APKBUILD b/community/ibus/APKBUILD
index 4131831b8be..220772d8a5e 100644
--- a/community/ibus/APKBUILD
+++ b/community/ibus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=ibus
-pkgver=1.5.22
-pkgrel=3
+pkgver=1.5.23
+pkgrel=0
pkgdesc="Next Generation Input Bus for Linux"
url="https://github.com/ibus/ibus/wiki"
arch="all"
@@ -25,10 +25,14 @@ subpackages="
source="
$pkgname-$pkgver.tar.gz::https://github.com/ibus/ibus/archive/$pkgver.tar.gz
0001-Use-more-portable-call-to-mktemp.patch
+ vala.patch::https://github.com/ibus/ibus/commit/dd4cc5b028c35f9bb8fa9d3bdc8f26bcdfc43d40.patch
"
install="$pkgname.post-install"
prepare() {
+ # Fix all shebangs from 'python' to 'python3'
+ grep -r -l '#!/usr/bin/python' . | xargs sed -i '1s|python|python3|'
+
default_prepare
NOCONFIGURE=1 ./autogen.sh
}
@@ -72,5 +76,6 @@ bashcomp() {
amove usr/share/bash-completion
}
-sha512sums="972da51eb5702692f13b4f4cff51b3765890e5a91f936b9fa6b6cafaf00f4d078dc39f14bd00f3883203d295d826647c509024dd197d726d4def8d13d45d71b4 ibus-1.5.22.tar.gz
-1e2e62ce52becf75d794c403e8f21bb72e8406aacbdbc5189f62a3b7c54166c40da0032d3f3865f5a23d9d2c782f974b7bcc9ba5ce437d9eb435dd3db3ff0b06 0001-Use-more-portable-call-to-mktemp.patch"
+sha512sums="b05637ff03a9977d0e130ea161ff7537c8c2f58953f84e4de4fce6369db1bb979cbd7773c083117cf9c51937537cb0219dc29c6455bb5707c1f7b6cb2d554dd4 ibus-1.5.23.tar.gz
+1e2e62ce52becf75d794c403e8f21bb72e8406aacbdbc5189f62a3b7c54166c40da0032d3f3865f5a23d9d2c782f974b7bcc9ba5ce437d9eb435dd3db3ff0b06 0001-Use-more-portable-call-to-mktemp.patch
+4de6deb8e188810807915c2ef4d4ca212f162e8b958f585183e6ae4d1792b684efe0bf15ccae17fd18cac699dc99683bbc612ca9111990338b3ab396d08e6263 vala.patch"