aboutsummaryrefslogtreecommitdiffstats
path: root/community/icedtea-web
diff options
context:
space:
mode:
Diffstat (limited to 'community/icedtea-web')
-rw-r--r--community/icedtea-web/APKBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/community/icedtea-web/APKBUILD b/community/icedtea-web/APKBUILD
new file mode 100644
index 00000000000..e9104f33a81
--- /dev/null
+++ b/community/icedtea-web/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=icedtea-web
+pkgver=1.6.1
+pkgrel=0
+pkgdesc="web integration packages for icedtea"
+url="http://icedtea.classpath.org/wiki/IcedTea-Web"
+arch="x86 x86_64"
+license="GPL"
+depends="openjdk7-jre bash"
+depends_dev="openjdk7 gtk+2.0-dev nspr-dev"
+makedepends="tar zip bash $depends_dev npapi-sdk"
+install=""
+subpackages="$pkgname-mozilla $pkgname-doc"
+source="http://icedtea.wildebeest.org/download/source/icedtea-web-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/icedtea-web-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr/lib/jvm/java-1.7-openjdk \
+ --datarootdir=/usr/share \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-jdk-home=/usr/lib/jvm/java-1.7-openjdk \
+ --with-pkgversion=Alpine \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+mozilla() {
+ pkgdesc="web integration packages for icedtea - mozilla plugin"
+ install_if="$pkgname=$pkgver-r$pkgrel firefox"
+ mkdir -p "$subpkgdir"/usr/lib/mozilla/plugins
+ mkdir -p "$subpkgdir"/usr/lib/jvm/java-1.7-openjdk/lib
+ mv "$pkgdir"/usr/lib/jvm/java-1.7-openjdk/lib/IcedTeaPlugin.so \
+ "$subpkgdir"/usr/lib/jvm/java-1.7-openjdk/lib
+ ln -sf /usr/lib/jvm/java-1.7-openjdk/lib/IcedTeaPlugin.so \
+ "$subpkgdir"/usr/lib/mozilla/plugins/libjavaplugin.so
+ return 0
+}
+
+md5sums="35d6712a5d9db69e8bd14ab68f94d748 icedtea-web-1.6.1.tar.gz"
+sha256sums="a9b46ab6c9dc303c89651143596bc5abea29242b9bdcabdd2dab7c606592c920 icedtea-web-1.6.1.tar.gz"
+sha512sums="dae39818f74a098289acd0736d27c2e68b10b603a3fb0a180cf4b6444345cbe71ab1ba77dfb198f053f9567bb18aa96de09049c3b595b3d292d142a7ae7d3ef9 icedtea-web-1.6.1.tar.gz"