aboutsummaryrefslogtreecommitdiffstats
path: root/community/icinga-php-thirdparty/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/icinga-php-thirdparty/APKBUILD')
-rw-r--r--community/icinga-php-thirdparty/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/icinga-php-thirdparty/APKBUILD b/community/icinga-php-thirdparty/APKBUILD
new file mode 100644
index 00000000000..7bcea7b12fe
--- /dev/null
+++ b/community/icinga-php-thirdparty/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=icinga-php-thirdparty
+pkgver=0.12.0
+pkgrel=0
+pkgdesc="Bundle for all 3rd party PHP libraries used by Icinga Web products"
+url="https://github.com/Icinga/icinga-php-thirdparty"
+arch="noarch !armhf !armv7 !s390x !x86"
+license="MIT"
+options="!check"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Icinga/icinga-php-thirdparty/archive/refs/tags/v$pkgver.tar.gz"
+
+build() {
+ return 0
+}
+
+package() {
+ install -dm755 "$pkgdir"/usr/share/icinga-php
+ cp -rT . "$pkgdir"/usr/share/icinga-php/vendor
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+sha512sums="
+c087261712d486fba026128d7fd06590e824024d192d4d5feea902dbdb7134fca7b0e1d82aa4a5246859ca55303a6aed40a57b5aaf37e6652abb68549c8c48ea icinga-php-thirdparty-0.12.0.tar.gz
+"